Help - Search - Members - Calendar
Full Version: Need Help With Nic Installation On Mandrake 10!
Linuxhelp > Support > Technical Support
pwmort84z
I just installed Mandrake Linux v10.0 a few hours ago, and I cannot install my NIC driver. It is not a driver that Mandrake comes pre-installed with, however Marvell (the manufacturer of my motherboard's built-on NIC) has a website with a linux driver download. The driver was made with kernel 2.6, and when I run it, it says my version is 3.3, so the software won't run. I also tried the - MISMATCH (or something like that) switch, and it doesnt seem to do anything to the automated install program. All of the files needed for the driver install are in a single .tar file. PLEASE HELP!


Thanks,
Paul
hughesjr
What is the motherboard model number ... and the board manufacturer. The best I can tell, Marvell makes network controllers, that are integrated with other companies motherboards ... but they don't make motherboards themselves.
pwmort84z
Right, the motherboard is an ASUS K8N-E Deluxe. Just the built on NIC is from Marvell.


Thanks again,
Paul
hughesjr
OK,

Your motherboard is an NFORCE3 board, which means you have an AMD64 processor. You need to know if you installed an X86_64 version of Mandrake (AMD64) or a x86 version of Mandrake (32bit). I looked for an X86_64 version and it seems Mandrake 9.0 is the latest version that supports X86_64 ... so you probably downloaded the x86 version of the iso. I will assume you have the x86 version.

I downloaded this file from ASUS:
http://www.asus.com/pub/ASUS/mb/sock754/K8...X/K8N_Linux.zip

After looking at the driver, I noticed that it is an older version of the NVIDIA Nforce drivers. So, I would recommend that you use the latest NVIDIA drivers instead. You can get the x86 version HERE. (If you are running an X86_64 version of Linux, that version of the driver is HERE ... but I think you are using x86)
-----------------------
All commands that follow are as the user root in a command terminal ... you can get this by opening a terminal window, and if you aren't logged in as root already, issue the command:

su - root

...then use your root password.
----------------------

You will need the kernel-source installed, to see if it is, use the command:

rpm -q kernel-source

If the result is (the number might be different):
kernel-source-2.6.3-19mdk

If the result is package kernel is not installed, then issue the command:

urpmi kernel-source

You should be prompted for a CD and kernel-source installed.

Once it is installed, you need to verify the number of the kernel source and kernel packages match your booted kernel ... do this:

rpm -qa | grep kernel

Mine says this:
kernel-source-2.6.3-19mdk
kernel-i686-up-4GB-2.6.3.19mdk-1-1mdk


Yours can be different ... if installed off the CDs, it will probably say:

kernel-source-2.6.3-7mdk
kernel-2.6.3.7mdk-1-1mdk


Next you want to make sure you booted off that kernel, use the comamnd:
uname -r

My result is:
2.6.3-19mdk-i686-up-4GB

yours should probably be:
kernel-2.6.3.7mdk

If that is what you have, you can get the latest driver from the x86 page above ... currently it is:

NFORCE-Linux-x86-1.0-0292-pkg1.run

Put the file in a directory ... then cd to that directory.

do the command:

chmod 755 NFORCE-Linux-x86-1.0-0292-pkg1.run

then do:

sh NFORCE-Linux-x86-1.0-0292-pkg1.run

follow the instructions in the installer to compile the drivers.
pwmort84z
Thanks so much. I followed your directions and everything went very smoothly. Finally I have my network card working!! Thanks again for the great advice!


Paul
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.