Help - Search - Members - Calendar
Full Version: Samba: Printer Share
Linuxhelp > Support > Technical Support
tubadude
So i have a 2 computer network setup in my apartment, 1 Linux (Mandrake 9.2) and one XP Pro SP2. I have samba 2.2.8a on the linux box. Im able to see my printer on my Laptop(XP) but i cant wirte to it. when i open the printer it says "Access denied, unable to connect" i think it may be because im not loged into samba from XP correctly. how do you log into the computer from XP w/ a user other than my windows login? or is it somthing else. Is there a better way to share a printer, cause thats all im using samba for....
Robert83
Hi,

This should solve your problem :

under the

[printer]

put this

guest ok = yes

this should now allow you to print...


(please note , if your guest account is disabled in winxp this won't work...)

for example

if my windows name is robert
and I want to print to a samba print server (only me noone else)

then in [global]
security = user

[printer]
valid users = robert

adduser robert
passwd robert
****
****
cd /etc/samba
smbpasswd -a robert
****
****

/etc/init.d/smb start

now when I connect from the winxp computer as robert (like this machinename/robert)
to the samba server where the user is robert , if the two passwords are identical than it will allow only me to print without ever asking a password, if they are not identical then it will ask for a password.

the choice is yours , depending on your current situation one of these settings will be fine for you


Sincerely
Robert B
tubadude
guest ok = yes; was already under the [printer] heading.... :-/
Robert83
Hi,

could you please paste your

[global]

and

[printer]

section here, so we can see what's wrong...and won't have to guess


Sincerely
Robert B
mehlkelm
Hi,

I am someone else, but I have the same problem. I tried with guest and with user.
Here is my smb.conf:

eris:/etc/samba# testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[printers]"
Global parameter guest account found in service section!
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

# Global parameters
[global]
workgroup = MSHEIMNETZ
server string = %h server (Samba %v)
obey pam restrictions = Yes
smb passwd file = /etc/smbpasswd
passdb backend = tdbsam, guest
passwd program = /usr/bin/passwd %u
passwd chat = *EntersnewsUNIXspassword:* %nn *RetypesnewsUNIXspassword:* %nn .
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
dns proxy = No
panic action = /usr/share/samba/panic-action %d
comment = Home Directories
invalid users = root
create mask = 0700
directory mask = 0700

[printers]
comment = All Printers
path = /var/spool/samba
valid users = sara
create mask = 0666
guest ok = Yes
printable = Yes
browseable = No

I hope someone else can see what went wrong here, its my first samba configuration..

Stefan
DS2K3
If you ahve mandrake, then you may well have webmin installed, try connceting to <ip address of server>:10000 and then use the samba tool to convert all unix users to smaba users, and if you use the same usernames, it should work ok. That normally solves it, I dont have to deal with Windows XP though...

D
mehlkelm
I have debian. But I could solve the problem just now. I added

printer admin = root, sara

to the printer section. XP box is a bit slow though, when giving the "print" command until it shows the print dialog....
maybe it is because sara's laptop connects to the lan wireless?

Stefan
Robert83
Hi,

you also need to use a print command... (man lpr) ...

and you need to enter use client driver = yes


Sincerely
Robert B
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.