Help - Search - Members - Calendar
Full Version: I Screwed Up My Floppy Drive
Linuxhelp > Support > Technical Support
popejeremy
I was using my Slackware 10 box, trying to configure its floppy drive in order to write an ext2 floppy for use in a Mandrake install on a different box. I was having little luck, and trying various things. I'm not sure exactly what I did to cause this to happen, but now when I try to mount the floppy I get this:

root@ruby:~# mount /dev/fd0
mount: /dev/fd0 is not a block device (maybe try '-0 loop'?)

I get similar error messages about it not being a block device whenever I try to do anything with the floppy drive now.

What did I do?
How can I fix it?
And...
How can I achieve my first goal of writing a floppy image to a floppy disk in ext2 format so that I can install Mandrake on this new box?

Thank you for any help you can offer.
Jim
You must not have formated the disk right. Try re-formating the disk and see where that gets you.
popejeremy
Um, this has nothing to do with the floppy disk. It's the disk drive. The drive won't even start reading a floppy that's in the drive, so it can't tell if it's formatted or not.

When I take the suggestion and use the "-o loop" it still fails to read the floppy correctly.
Jim
Will it work on some disks but not others?
hughesjr
sounds like you have messed up the /dev/fd0 file (or the link it points to).

First do this:

ls -al /dev/fd0

In slackware 10 it says this:

lrwxrwxrwx 1 root root 8 2004-10-25 01:11 /dev/fd0 -> floppy/0

then do:

cd /dev/floppy
ls -al


it should say:

total 0
drwxr-xr-x 2 root root 0 2004-10-25 01:11 ./
drwxr-xr-x 13 root root 0 2004-10-25 06:11 ../
brw-rw---- 1 root floppy 2, 0 2004-10-25 01:11 0


If you have those files, then the problem is with the individual floppy you are trying to mount...if you don't we will need to figure out how to create the block device file.
popejeremy
Thanks. I tried your suggesion and here's what I get. Please note that there was no /dev/floppy. This means one of two things. You made a typeo and you meant /mnt/floppy, or this thing is more screwed up than I know. Thanks so much for your help.

root@ruby:/mnt/floppy# ls -al /dev/fd0
-rw-rw-rw- 1 nobody nobody 1474560 2004-10-24 13:26 /dev/fd0
root@ruby:/mnt/floppy# cd /dev/floppy
-bash: cd: /dev/floppy: No such file or directory
root@ruby:/mnt/floppy# ls -al
total 17
drwxr-xr-x 3 root root 1024 2004-10-24 13:26 ./
drwxr-xr-x 5 root root 4096 2002-03-16 02:34 ../
drwx------ 2 root root 12288 2004-10-24 13:26 lost+found/
hughesjr
I meant /dev/floppy ... very wierd.

Looks like you copied a file to /dev/fd0 ... it is not the special character file.

What version of Slackware are you using?
popejeremy
Slackware 10.
Corey
I may be missing something, but, he first attempted to mount the /dev/floppy device. Shouldn't he be mounting by using the directory name that is listed in /etc/fstab ?

For example, on my debian system, i would just use:

mount /media/floppy

Referencing the mount point and not the device. I'm on a windows system now, so i can't test, but i may be wrong and you may be able to reference either.
hughesjr
you should be able to do a mount like this:

mount /dev/xxxx /mnt/xxxx

or if the device is in /etc/fstab, you should be able to do the same mount with just the path like this:

mount /mnt/xxxx

I think the problem is that the special device block file was overwritten with a regular floppy image ... if you look at his file at /dev/fd0, it is the size of a floppy image...
QUOTE
-rw-rw-rw- 1 nobody nobody 1474560 2004-10-24 13:26 /dev/fd0


I am going to boot my slackware 10 and see if the /dev files are created dynamically or are part of the /dev directory. If the files are static, I'll post a tar file that contains the file you need in the /dev directory.
hughesjr
OK,

in my slackware 10 system I am using udev for device creation ... I think that is the default (I didn't do anything special for it to be installed on my slackware partition).

If I boot on a different OS and mount the slackware partition to look, the /dev/floppy directory is not there, but it is created on bootup into slackware by udev, so I can't just give you a file to put in the /dev directory.

Since the file /dev/fd0 (on your system) is not the right one, do this as root ...

mv /dev/fd0 /root

This should move the 1.4 mb file named fd0 (owned by the user nobody) to the /root directory ... then reboot your system and see if udev creates the proper files and links. After reboot, do:

ls -al /dev/fd0

see if it gives this output:

lrwxrwxrwx 1 root root 8 2004-10-27 00:56 /dev/fd0 -> floppy/0
popejeremy
I did what you said and gave it the 'ol "ls -al /dev/fd0" and it tells me

/usr/bin/ls: /dev/fd0: No such file or director

So, it didn't respawn or get put there automagically. I must have deleted the proper fd0 file and now I don't know where to get a new one.
popejeremy
Hey everybody, thanks for the help you offered, but I fixed it myself by doing this:

mknod /dev/fd0 b 2 0
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.