Help - Search - Members - Calendar
Full Version: Iomega Zip100 Ide/atapi Drive Install
Linuxhelp > Support > Technical Support
bgagnon
Hello Everyone, First of I am totally new to Linux. I read Joey's internal ide zip drive guide, but I ran into a brick wall. When I entered the command "cd /usr/src/linux" there was no Linux directory. I am totally lost trying to install this zip drive. It works fine in windows98 so I know its not defective. I am running suse linux 9.1 and it works great. In fact, until I need to use my zip drive I may not run windows for a long time. I went to the Iomega web site and got their tgz file which I "untarred" and derived the iomegaware folder iwcl-lnx-x86-10-english. This folder is supposed to have the drivers and the iomegaware software. It has two files, a readme.txt file and an executable file called iw. The readme file isn't much help for me as far as how to install the drivers, and I don't care about the software. I figured I must have to run that iw executable file. So, being a window's user I clicked on the file and of course nothing happened. I also found that entering iw on the command line also did nothing except tell me the command could not be found (I am logged in as root). Thinking that maybe the file already executed I went ahead and mounted the drive. After following the Iomega instructions I still have no zip drive. Pls help. Bob Gagnon
Jim
first the problem with /usr/scr/linux That simply means that you don't have the linux source rpm installed. You need to find and install the kernel-source rpm for your kernel. Here is a link to one for the 2.6.4-52 kernel

kernel-source-2.6.4-52.src.rpm

DO NOT use that rpm unless you have the kernel version. If you don't and you can't one to match, come back and one of us will find it for you.

You should be able to follow the rest of the guide form there on out. I am not sure how the Iomega drivers work off thier web sight. My zip drive wored with out any extra support. I would try to finish Joey's guide and see where that gets you.
michaelk
I am not real familar with SuSE but I would think you could install the kernel source using yast from the install CDs.

BTW the Iomega tools have never worked on any of my PCs.
hughesjr
you can install the kernel-source off the CDs if you haven't done any security updates ... if you have, you can still install the kernel source off the CDs .. then do updates again.

I also haven't had the iomega tools work for me in linux.
bgagnon
I verified my kernel is 2.6.4-52-default. I D/L the update per Jim's instructions (2.6.4-52)and installed it as prompted. It took a couple minutes to install, so I guess it did. I still could not access Linux (cd /usr/src/linux). Instead I found a directory called "packages" where I should have found "linux". The "packages" directory contains 5 subdirectories; build, rpms, sources, specs, srpms. Is there something else I can try, or did I not do this correctly? I installed linux 9.1 with 1 dvd. Where on the dvd is the kernel source that hughesjr said to install? Wouldn't the installation procedure have installed the latest kernel on the dvd? Thanks for the info.
hughesjr
go to the directory /usr/src

what are the sub directories there...

(use the command ls -al)

If you are using the kernel version that you installed the kernel-source for, all is well...but sometimes there no link for /usr/src/linux that points to the current source location.
bgagnon
If I go to the /usr/src directory and use the command ls -al I get the following list:

total 0
drwxr-xr-x 3 root root 72 Oct 19 14:31 .
drwxr-xr-x 12 root root 344 Oct 19 14:47 ..
drwxr-xr-x 7 root root 168 Oct 19 15:01 packages
hughesjr
That means that the kernel source package did not get installed.

open a terminal window ... if you are not logged in as the root user, issue this command:

su - root

go to the directroy where you downloaded the kernel-source file .... probably the home directroy of the user that you usually login as...

cd ~username

look for the file:

ls | grep kernel

If it is there, install it via this command:

rpm -Uvh filename
bgagnon
The updated kernel was D/L to /tmp. There were all kinds of junk in there from past attempts to install the kernel update. I deleted everything in the tmp folder and D/L again (two hours with my dialup service) last night. After the D/L there are 7 folders and 1 file in the /tmp. Only 1 folder contained an rpm file. It is /tmp/kde-root; the rpm file is konquerorrdqogb.6.4-52.src.rpm.

I followed your instructions, ls | grep kernel; nothing was found. Should I try rpm -uvh konquerorrdqogb.6.4-52.src.rpm
Thanks
hughesjr
OK ... we aren't getting anywhere this way. For some reason, the file is not installing.

Try this ...

Open Yast2

Double Click Install and Remove Software

Set the filter to Package Groups

In the left window, Select Developement -> Sources

In the right window, select the check-box for kernel-source

Then click the accept button at the bottom right...

That should install kernel-source...
bgagnon
Ok, well I must have a SUSE linux version 9.1 from the planet Mars because it seems my config is different then everyone elses. I went into Yast2 and after selecting package groups/development there was no choice listed for "sources". The only choices listed were Languages, Libraries and Tools. I looked around in yast2/package groups and saw the catagory zzzall. Going down the zzzall selections on the right I saw "kernel default". I selected update and hit accept. It prompted me for installation cd1. I tried to change the path to where I stored the D/L kernel update file, but I got the response "error: media not attached". I also let it install from the installation dvd, but I'm sure it just reinstalled the same kernel that was installed during the initial installation because when I went to usr/src there was still no linux folder.
hughesjr
Is it SuSE 9.1 Professional or 9.1 Personal ...

In 9.1 personal, they don't provide the same developement capibility as in the professional version.
bgagnon
Its the Personal version.
bgagnon
I've been using a friend's SUSE 9.1 personal version to see if I would like to learn more about Linux. Well I do like working with Linux so I am going to get the professional version and install it. I'll let you know how I made out with all of your advice with the pro version. Thanks very much for the assist. Just one more question for now. Would it be best to completely uninstall the Personal version first, or can I just install the Pro version on top. If I need to unistall first, whats the best way to do that? I have no data to worry about backing up.
hughesjr
You can install the professional version righ ton top of the personal version without removing it.
bgagnon
Ok; I installed the professional 9.1 on top of the personal version and everything went nicely. I used Yast to install the new kernel update (which also went smoothly) and now there is a linux directory at /usr/src (/usr/src/linux). When I go to the command line and type in "make menuconfig", I get the msg "make: command not found". I have been going thru the manual and it says the same thing for configuring the kernel (use the command--> make menuconfig). I looked the "make" command up in the man pages and its in there, although I don't understand what I read. Is there a path problem or something, that it doesn't know where to locate the command? I tried to locate the "make" command but I didn't have any luck. One of my books says the man pages will tell where commands are located. Can you help this novice a little more?
hughesjr
good job smile.gif

Now you need to add the developement packages so you can compile items from source. You need to go into YAST -> Install / Remove Software

In filter, select Selections -> C/C++ Compiler and Tools, then in the right window, select and install (at least):

autoconf
automake
build
gcc
gcc++
glibc-devel
libgcj
libstdc++-devel
libtool
m4
make


(you can install all the Selections -> C/C++ Compiler and Tools section if you want)
bgagnon
I added all the selections shown at -->c/c++ compliler and tools. When I run /usr/src/linux make menuconfig It doesn't offer anything to make selections; I get the following: -include /var/adm/running-kernel.make
The .config file is a merged configuration; please remove it by hand before creating your own. You can use one of the files arch/i386/defconfig.* as a template.
make[1]: *** [check-meta] Error 1
make: *** [menuconfig] Error 2

I have no clue. I tried looking around the site for some ideas, but didn't find a solution. I'll keep looking. Is menuconfig a file or a utility? Can you give me some more info?
bgagnon
I don't know what I was doing wrong yesterday; Today I was able to get menuconfig running. On my system, I had to select 'device drivers b4 I could get to block devices ( I'm referring to Joey's zip drive install guide). After getting to block devices I did not see 'include ide/atapi floppy support'. At this point, hughesjr, I think I just need to nose around and get familiar with menuconfig. I will let you know when I get to another brick wall or when I get this zip thing configured properly, In the meantime all this messing around is teaching me a great deal more than I ever knew about Linux, and its a lot of fun to 'boot'. Thanks a lot for all of your help.
hughesjr
Joey's guide is for a 2.4.x kernel ... and you have a 2.6.x kernel, so things are going to be slightly different.
bgagnon
Well that probably accounts for the differences that I found while going thru Joey's procedure. Also, I neglected to say that while I was asking why "make menuconfig" didn't work, I also had a problem with the boot loader. I ran the system repair procedure from the install dvd. It fixed the boot problem and then I was also able to run 'make menuconfig'. when suse boots up it calls the iomega drive "hdd", and so now I'm trying to mount the drive as hdd. I also am getting msgs that the fstab and mtab files have no info about the zipdrive, so I am dealing with that. I think once I get the proper paths set up in the mounting procedure it will probably work. I must be getting close because now I have 4 icons on my work desk called "zip disk hdd" that I'm trying to delete (and can't do it, but I will figure out how).
bgagnon
I was able to get linux to recognize the zipdrive and I mounted it sucessfully. I tried reading the contents of a zip disk but could not (I guess because the contents were dos formatted). Anyways, You guys solved my basic problem; Thank you. I continued playing around until I managed to screw things up so that I corrupted the hdd block file (among other things). Long story short, I reformated the hard drive and installed linux without windows. Now I need to update the kernel again via the 39.5mb file I downloaded from one of the mirror sites recommended by Jim. I have a question about that but since it is a new topic, I will start a new topic.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.