Help - Search - Members - Calendar
Full Version: Mandrake 10.1 Nvidia Drivers
Linuxhelp > Support > Technical Support
mdphreak27
I just installed mandrake 10.1 with kernal version 2.6.8.1-10mdk. Im tring to install the nvidia drivers for my vid card but it keeps giving me an error related to my kernal version.... the driver only lists up to mndrk 10.0 kernal ver 2.6.2 or so. should I asume thats the reason why? if thats the case can I and should I downgrade my kernal to what the driver can deal with? this wouldnt really be an issue if I wasnt trying to dualview, but unfortunately i cant do that without the driver.....
hughesjr
You should be able to download the latest NVIDIA drivers from here:

http://www.nvidia.com/object/linux.html

(You probably want the IA32 version unless you installed IA64 or AMD 64 OS)
------------------
You also need to install the Mandrake package kernel-source.
------------------
Then follow the readme to make it work:
ftp://download.nvidia.com/XFree86/Linux-x...6111/README.txt
mdphreak27
thats the driver I tried installing. i tried different methods ie... running it, extract then make install, and i tried a patch thats supposed to fix the problem. however i still got the error about me kernel even though the patch is supposed to fix that. I dont know where to go from here....
hughesjr
I haven't installed Mandrake 10.1 yet ... but I am downloading it right now.

I will install Mandrake 10.1, then I will try to install the NVIDIA drivers.

I'll post the results here (with a howto if I am successful).
Jim
What is the specific error about your Kernel?
mdphreak27
well after a little searching I found out how to get the driver to install....however now when I boot into linux I only get a blank screen....wtf? anyone know where to go from here?
this is the method that alowed me to do the install

(0.1) install kernel source

$ urpmi kernel-source-2.6

(0.2) close X session

$ service dm stop

(1) extract the content of the installer

$ NVIDIA-Linux-x86-1.0-6111-pkg1.run -x

this will create the following directory: NVIDIA-Linux-x86-1.0-6111-pkg1/

(2) now enter that directory and go to usr/src/nv. replace the switch constant on line 3697 of the file nv.c to

PM_SUSPEND_MEM

(3) back to first level directory (NVIDIA-Linux-x86-1.0-6111-pkg1/)

$ cd ../../..

(4) as root run

$ ./nvidia-installer

(5) edit /etc/modprove.preload and add the following entry:

nvidia

(6) edit /etc/X11/xorg.conf and replace

Driver "nv" with Driver "nvidia"

(7)

$ modprobe nvidia
$ service dm start
hughesjr
I have completed my install of Mandrake 10.1 Community ... and as you have already stated, there is a bug in the code for the NVIDIA propreitary driver and the 2.6.8.1 kernel. Here is how I got the Driver to install (you already did most/all of this ... but it is also recap for others as well):

1. Install kernel-source with this command (all commands are as root in a console window):

urpmi kernel-source-2.6
(pick the 2.6.8.1 kernel source)

2. Make the driver file executable:

chmod 755 NVIDIA-Linux-x86-1.0-6111-pkg1.run

3. Extract the kernel driver, so we can edit the code:

./NVIDIA-Linux-x86-1.0-6111-pkg1.run -x

4. Go into the directory:

cd NVIDIA-Linux-x86-1.0-6111-pkg1

5. Edit the file usr/src/nv/nv.c (under your curent directory) and replace the text PM_SAVE_STATE with PM_SUSPEND_MEM. (In the current driver, this is only on line 3697).

6. If you are in GUI mode ... shift to console mode with this command:

init 3
(login as root, and go back into the NVIDIA-Linux-x86-1.0-6111-pkg1 directory)

7. Install the driver with the command:

./nvidia-installer

8. edit /etc/modprobe.preload and add the following entry (at the bottom of the file):

nvidia

9. Now edit the file /etc/X11/xorg.conf and replace nv with nvidia and add load "glx" to the Section "Module" section of the file.

10. Load the nvidia module:

modprobe nvidia
(in some cases, you may need to load agpgart first with the command modprobe agpgart)

11. Test and see if X is going to start:

startx

12. If that works, reboot and make sure everything runs at startup.
----------------------------
Now to answer your specific issue ... do you have an NVIDIA Nforce 2 chipset or an SiS Chipset motherboard? If so, you need to add nvidia-agp before nvidia in the file /etc/modprobe.preload ... or if you have an SiS chipset (I have one on my test machine), you will need to add sis-agp before nvidia in the /etc/modprobe.preload file.
mdphreak27
If this helps at all heres what I have...
Motherboard - Gigabyte GA-7VAX
MB Chipset - northbridge:via-kt400 , southbridge:via8235
video card - Nvidia GeForce4 Ti 4600


I also have a stupid question, now that i cant see anything in graphical mode....how do I edit files from the text-based console?
I'd like, if nothing else, to be able to return to my previouss state without reinstalling .....again
mdphreak27
update - i figures out the editing so i dont need help wit that any more

in reguards to the modprobe.preload file it already has nvidia-agp in it

I did go back and erase the nvidia line from modprobe.preload and edited /etc/X11/xorg.conf and switched back to nv from nvidia so I can see again

I would still like the driver installed and functional....
hughesjr
Make sure there is not a load "dri" in the load section.

Were there any messages in /var/log/X.org.0.log
mdphreak27
what file do i want to make sure load "dri" in not in?
hughesjr
sorry smile.gif

in /etc/X11/xorg.conf
mdphreak27
no load "dri" is not in the xorg.conf file
mdphreak27
Well I went back and tried the following (very similar to what i tried before) everything was the same exept making sure that Load "glx" # 3D layer was no longer commented out in the "Module" section of xorg.conf and adding alias char-major-195* nvidia into modprobe.preload.

well this (unlike before) didnt load into x and give me a blank screen, instead it gave me the "no screen detected" error (or something to that effect) and stayed at the command prompt

so off to do more searching......

btw thanks for the help so far...
mdphreak27
ok I got the driver up and running. i figured out i have to type "modprobe nvidia" and then startx and the driver load s up
now , however i have to do that every time i start up my machine
what file whould i throw the modprobe comand into for it to run at startup?
hughesjr
it would go into the file:

/etc/modprobe.preload

(after the agp driver)
mdphreak27
tried it, didnt work
hughesjr
strange .... you could put it in as the last line of the file /etc/rc.local

/sbin/modprobe nvidia
mdphreak27
well the command modprobe nvidia is being entered somewhere durring the startup proccess, but i still dont get my graphical login, its still text based
hughesjr
Looks like the display manager starts before rc.local runs, so the NVIDIA driver isn't loaded when the Display Manager starts. We probably just need to load the NVIDIA driver sooner. Try this:

remove the lines from rc.local and create a file in /etc/init.d/ named load_nvidia

put this inside the file:

CODE
#!/bin/bash

case "$1" in
 start)
       /sbin/modprobe nvidia
     ;;
 stop)
       exit
     ;;
 *)
       exit
esac


Now save the file and chmod it to be executable:

chmod 755 /etc/init.d/load_nvidia

now create a link to make it load on run level 5 ... like this:

ln -s /etc/init.d/load_nvidia /etc/rc5.d/S07load_nvidia

it should insert the nvidia driver after hardware detection and before the network starts on runlevel 5 (gui mode).
mdphreak27
Awesome....that did the trick, thank you
chag
Hi,

I found answers to my Nvidia problems here smile.gif. I've just upgraded my mandrake 10.0 official to 10.1 official, encountered almost all the problems you talked about in this thread and so, found all the solutions.

Today, Nvidia released a new version of their driver (Nvidia IA32 linux drivers) . In the README, I found another solution to the problem of module not loading at startup :

QUOTE
Q: The kernel module does not get loaded dynamically when X starts;
  I always have to do 'modprobe nvidia' first.  What is wrong?

A: Make sure the line "alias char-major-195 nvidia" appears in
  your module configuration file, generally one of "/etc/conf.modules",
  "/etc/modules.conf" or "/etc/modutils/alias".  With 2.6 kernels,
  this file is normally /etc/modprobe.conf.  The correct way to update
  this file is distribution dependant, and it is often not a good idea
  to edit this file directly.  Please consult the documentation that
  came with your distribution for details.


Hope it helps

Chag
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.