Help - Search - Members - Calendar
Full Version: Need Help Mounting Xp Partition
Linuxhelp > Support > Technical Support
dbooster
I just reinstalled suse 8.1, but for some reason it didn't autoconfig my xp partition to mount like it normally does. Easy enough to fix I figure...

I added this to my fstab:
/dev/hda1 /mnt/nt ntfs user 0 0

ok. It automounts fine, but only root has access. I thought the "user" up there would give all users access, but nope, I can't get in unless I su to root. I read on one forum that it would work if I added noauto after user, but nope. After I mount it as teh user it is still readable only by root. I suppose I could su to root everytime I needed something on xp, but this would be awfully inconvient. Please help!!

-dave
dbooster
anyone??
chrisw
it is not advisable to write to a NTFS partition from linux
you should just read from it for now..i think you have
to compile in kernel support to write to a NTFS partition
anyway, to keep people from writing to such partition.
dbooster
I don't want to write to it - just read it. I assume it is possible to allow a regular user to read the ntfs drive because suse usually automatically sets it up to allow me to do this. I just can't figure out how to set this up myself and that's my question. I can get the root to read it, but not the regular user.
wwpusa
Can't u just set permissions for usr? wink.gif
dragons_fyre
Perhaps I'm missing the topic of this post, but if Not here I go.

As far as the partitioins go I just created one large primary partition. From there I setup an extended partition. Then I created three logical drives on the extended partition. The first logical drive I set for 6 gigs which is where the main part of linux is set with the file system hex designation as 83 I believe. Then the second logical drive was for my swap and that was 600 megs and set that as 82 I think. I may have those mixed up. Then my third logical drive is a 3 gig shared drive which I use to share files between linux and windows. I used a FAT32 file system for that. I haven't had any problems with users and what not having it setup like this. Like I said I don't know if I am off subject or not. But hoped it helped
dbooster
Hmm... I guess I'm not being clear.

I have 2 partitions: ntfs and linux. When I normally install suse, it creates a folder on my desktop (in kde or gnome) that gives me read-only access to my ntfs drive. It otherwords, it automounts the drive for me, and gives access to both user and root.

When I reinstalled suse this time, it didn't provide this folder for me. I suppose I missed the option in the install. Anyways, so I am trying to provide the same thing on my own. But it isn't quite working.

When I mount the ntfs drive, the premissions are automatically set to read-only for root and nothing for the user. That is, root has ro access, but user can't even view the drive. I can't figure out how to change this. I can't chmod the dir - it just won't let me. I tryed setting the user option in the fstab, but that didn't work either. I have no idea what else to try!

wwpusa: If chmoding the folder isn't what you meant for setting permissions of user, than what did you? Keep in mind, I'm still very much a linux newbie (dispite being a CS grad)
Corey
Check out the manpage for mount and look for the mount options for an ntfs filesystem. Check the options for "uid" and "gid".
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.