Help - Search - Members - Calendar
Full Version: Cdrom Not A Valid Block Device
Linuxhelp > Support > Hardware Support
jh_admin
Hi,

I have a server running redhat 9 - kernel 2.4

I am trying to mount the cd drive and am getting the following reponse to the command mount /mnt/cdrom

mount: /dev/cdrom is not a valid block device

Looking at dmesg shows the cd rom was detected at boot time.

cat dmesg | grep -i cd
hdc: MATSHITA CR-177, ATAPI CD/DVD-ROM drive

From /etc/fstab

/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0

Doing ls –l /dev/cdrom I can see /dev/cdrom is pointing at hdd

lrwxrwxrwx 1 root root 3 Feb 10 2004 /dev/cdrom -> hdd

In this, what is hdd? Is it related to ‘hdc’ from dmesg?
Should /dev/cdrom be pointed at /dev/hdd instead?

I have tried finding a solution on the web without success, hence this post.

Thanking you in advance,

jols
michaelk
Have you changed the hardware configuration lately? Do have have anything installed on the second IDE controller slave position?
/dev/hda - 1st IDE controller master
/dev/hdb - 1st IDE controller slave
/dev/hdc - 2nd IDE controller master
/dev/hdd - 2nd IDE controller slave
and so on.....

Your correct /dev/cdrom is linked to the wrong device. It should be hdc and not hdd.
To change /dev/cdrom from hdd to hdc, log in as root (via su)
rm /dev/cdrom ( deletes existing link)
ln -s /dev/hdc /dev/cdrom (create new link)
tall_chris_11
If you run an older kernel with legacy scsi cdrom you will need an option like:
append="hdc=ide-scsi"
in your /etc/lilo.conf file. If you run a newer kernel, like 2.6.x, and didn't compile in this option, make sure you remove that line(or at least the hdc=ide-scsi part of it).
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.