Help - Search - Members - Calendar
Full Version: Dns Or Browser Problem?
Linuxhelp > Support > Technical Support
naperdave
I am adding my laptop RH* to small net with dial routing.

This laptop can ping IP numbers & "google.com", however not websites with mozilla nor Konqueror. Websites cannot be found or unknown host.


Resolv.conf is nameserver xxx.xxx.xxx.xxx (2) and is same as Fedora computer that works fine. I also added 192.168.xxx.xxx (gateway) thinking that might help but not so.

Iptables -L shows chain policies accept only (firewall Disabled). I also tried disabling firewall with lokkit & rh-config-seclevel but always shows "high", even after network restart & iptables restart.




Any ideas,Thanks in advance

Dave
Robert83
Hi,

I think you are using Red Hat 8.2 (with that I had similiar strange behavior, and was not able to turn off the firewall from gui)

try turning of the firewall via the console

CODE
setup

or
CODE
/etc/init.d/iptables stop

and see if webpages show up correctly,
is there a proxy server running perhaps?

Sincerely
Robert B
naperdave
I'm in good shape if I got the "twin brother".

I haven't heard of setup before and have done init.d iptables stop.

Please note: computer on other floor I just appended appropriate files to run through same linux router has same redhat8 as above and runs absolutely fine. Also cleared iptables and shows only policies accept with iptables -L, and -config-seclevel still shows "high" on that computer no matter how I try to shut off as well (but that comp works!)

Possible permissions issues w/ Mozilla,Konqueror on laptop?


If no help will have to install Fedora core.


Thanks for help!
Dave
Robert83
hi,

try this

type in console
if iptables is running
CODE
iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P FORWARD ACCEPT

do NOT! restart the computer since these settings above will be set back to default on the next reboot , which I think is blocking your port 80, did you try e-mail by the way? pop3 or smtp works to ? icmp works, since you woldn't be allowed to ping stuff

never do this on a firewall, we just changed the default policies to ACCEPT for all 3 chains

and try browsing the web now, I think that somehow port 80 [b] must [/] be blocked by the firewall on that computer...

when you try to open a webpage with Mozilla or Konqueror what happens ? does a error page apear? what is the error? or nothing appears at all?

Sincerely
Robert B
naperdave
Thanks "Twin Man", I'll try soon when I get back tonight.

Is having these default policies ok on lan? That's what I had tried for troubleshooting means except that I had saved before-those default policies is actually what I get after reboot with "cat /etc/sysconfig/iptables". No, I did not try email.
I still need to keep NFS on lan and have found excellent info regarding this. I'm also going to look into installing Firestarter and Squid soon.


For all practical purposes I still can't find a quick way to disconnect/restart ppp0 with browser so phone or other person can use a browser on this dial-up. Walking to router to deactivate/activate ppp0 isn't what I anticipated. Do you know if I can somehow run a script through Mozilla that could run when someone gets off line? I suppose I need a separate line or high speed internet, along with Fedora core to remedy these two problems. Any suggestions on that matter-I've run out of resources.


Thanks again,
Dave
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.