Hi,

I'm running RHEL workstation v3. I connect multiple machines to a central raidzone machine via NFS. The central raidzone exports a set of directories and the individual workstation mount these directorives via the automounter and the file /etc/auto.master. Usually all works well and the directories are mounted where they are suppose to. However, recently a second automounter process spawns at the same time I lose the connection between my workstation and the raidzone.

if I type in ps -aux the following line appears twice:
/usr/sbin/automount --timeout=60 /nfs/raidzone file /etc/auto.raidzone

if I reboot the machine the above line only appears once (as it should). I was thinking that perhaps the NFS connection is getting lost somehow and the automounter is restarting in an attempt to reconnect. However, all that happens is that my terminals will no longer bring up a prompt so I get stuck and there's nothing I can do.

I have tried logging in as root when this happens and tried the following:

/etc/init.d/autofs stop (as well as restart)
umount -f /mnt/point

Both of these tell me that the device is busy and I can't unmount. Does anyone know what might be going and how I can avoid losing my connection? One other note, I believe the problem is on the workstation side because I have multiple machines connected to the raidzone and if one workstation exhibits this problem the others don't crash or necessarily have the same problem. Thanks so much.


-NifflerX