Help - Search - Members - Calendar
Full Version: Prob With Eth0
Linuxhelp > Support > Technical Support
imaginaxion
i had this all working before with my LAN connected to eth0 and assigning IP's to the comps connected using dhcp.

i have just got adsl and was wanting to set that up on eth1 and share the internet connection to the network

i starting setting up the ppoe and adsl account on the linux box and it con't connect but anyway thats the next issue, for the mo it seams to have broken my dhcp sever setting i cant stop or start or anything to the service.

i'm using mandrake 10 and i used to write "service dhcpd restart" for eg and it would give me that
stopping dhcpd [ OK ]
starting dhcpd [ OK ]

now it does nothing no error nothing
eth0 is also down and i have no idea how to get it back up

thanks in advance for you time
Robert83
Hi,

you can try a

ifconfig eth0 up

command , maybe that will help (or show what is the problem or something)


Sincerely
Robert B
imaginaxion
i tried that but it did nothing. i also tried it with my other card eth1 and i worked fine.
if i type ifconfig it show me the details for eth0, eth1 and lo but the eth0 has no ip address and like i said that eth0 up or down command made no difference

help
michaelk
Post the file:
/etc/sysconfig/network-scripts/ifcfg-eth0
imaginaxion
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.0.151
NETMASK=255.255.255.0
NETWORK=192.168.0.0
BROADCAST=192.168.0.255
ONBOOT=yes
MII_NOT_SUPPORTED=no
WIRELESS_ENC_KEY=""
imaginaxion
doesn't look like anything wrong
what now?
this is completely baffling me
imaginaxion
i also tried
ifconfig eth0 192.168.0.151 netmask 255.255.255.0
this added the address to the nic properties when i used the ifsonfig command and seemed to work but when i reboot it fails again and it is set to start at boot - see above

another thing is (maybe this will help or make the situation worse i'm not sure) i had dhcp running and its doesn't seam to exist anymore either

atleast when i try start it it just does nothing aswell no error nothing
Robert83
Hi,

what does
CODE
cat /etc/modules.conf


show for eth0 ?

Sincerely
Robert B

ps.: you already checked your /var/log/messages.log file for any strange things regarding eth0 ?
imaginaxion
i tried that cat /etc/modules.conf
result:
alias eth1 8139too
alias eth0

and as for looking in messages:
i'm not too sure what i'm looking for and it took me about 15 mins to scroll thru but i found this:

Sep 1 22:13:49 localhost ifplugd(eth0)[3902]: Using detection mode: SIOCGMIIPHY
Sep 1 22:13:49 localhost ifplugd(eth0)[3902]: Initialization complete, link beat not detected.
Sep 1 22:13:49 localhost network: Bringing up interface eth0: failed
Robert83
hi

the problem is there... smile.gif

if eth0 is the same type of ethernet card as eth1 then just do the following

modify your /etc/modules.conf so that this is in it

alias eth1 8139too
alias eth0 8139too

and then save it ... restart the computer and it should work


Sincerely
Robert B
imaginaxion
sorry that was a typing mistake they are both

alias eth1 8139too
alias eth0 8139too
sad.gif
imaginaxion
hey sorry for all this hastle but i really don't know what to do. i have tried uninstalling the device and reinstalling but it still won't start at boot.

where to from here? i know with windows when it seems to get stuck like this it usually means reinstall.
i don't really want to do that.

i think this started when i tried to set up my adsl but i have no idea what i did that would have done this.
michaelk
Are you sure that your ADSL is using eth1 and not eth0? When I had ADSL I couldn't assign an IP address to the NIC connected to the modem until I established a network connection. I was using Roaring Pengiun PPPoE.
imaginaxion
the thing is i have also tried unpluging the network cables incase of any conflicts or anything so that i could try get it up and the configure them for the respective networks.
this ahs not helped anyway
imaginaxion
hi thanks everyone for the help

i ended up reinstalling mandrake and its working now (i thought you only had to do that in window but then again i am a newbie)

i'm now trying to set adsl up but i will start a new thread for that later if i can't figure it out first
(hope i don't go mess things up again)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.