Help - Search - Members - Calendar
Full Version: Last Few Gentoo Issues.....
Linuxhelp > Support > Technical Support
Ok, so I have a few wiered Gentoo issues, and since its taken me a month to get around to clearing up the first major ones, I thought I would try to get help clearing up these last ones that would probably take me for ever to fix.

First, the biggest one, is a can't get opengl to load right. I installed the nvidia module from the nvidia websight since I couldn't get the emerged version to work. So pointed opengl to nvidia with opengl-update nvidia after I emerged the opengl package just to make sure things were good. Than when I do the glxinfo | grep direct command, I get a bunch of "not found" errors, instead of a simple "Direct rendering Yes" message.

Second: Something really wiered happened with my emacs intall. I did a simple emerge emacs and it finished with no errors. But when I type emacs into the command line, this is what happens.
jim@argento jim $ emacs
Undefined color: "black"
jim@argento jim $

Ya, exactly, what on earth do I do with that?

Third, and probably the oddest one, when I open Thunderbird, and only thunderbird, the font is huge, like 16 18pt something like that, in all the menus and buttons and stuff, the only program that does it. I tried screwing around the with preferences and stuff, but I just couldn't get it to go down. Thoughts?
When it comes to the NVidia drivers, it's best to use the ebuilds, it is much easier to determine what the problem is when you stick to the ebuilds. How did you compile your kenerl? Is there very much software on your system that you compiled yourself without the aid of an ebuild? This can sometime lead to problems which is why the Gentoo team included a method to compile the software on your own and using their ebuild to merge it with your system.

Your glxinfo command will probably cause errors because you're your grep'ing for "direct" and not "Direct", remember, linux is case sensitive for most things.

Ensure that your /etc/X11/XF86Config (or /etc/X11/xorg.conf) under the device section has "nvidia" instead of "nv".

As for emacs, I have no idea, i don't like emacs, too much bloat.
Well I love my emacs because I use it for doing bigger stuff than just making small changes to config files. So when I am working on an entire web page or a huge block of code the "bloat" comes in handy.

I couldn't get the emerge for the NVIDIA drivers to work. I have it working now. Its just the glx thing. Regardless of if the D is capitlor or not, it still doesn't work, and anything glx, like my screen savers doesn't work. I am not to worried about it because things seems to be running fine with out it.

And I still have no idea about the thunderbird font issue
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.