Help - Search - Members - Calendar
Full Version: Red Hat Won't Boot Up
Linuxhelp > Support > Technical Support
aserty
I installed Red Hat Linux on my hard drive drive and everything in the install process went fine, but then I tried to boot it up and it went through all the text stuff scrolling down the screen and then the monitor turned off and the hard drive acitivty light went off. So I sat for a few minutes and rebooted it, but the same thing happend. So I tried to do the recovery thing on Linux and bootup but it still didn't work.

I'm pretty new at this, so please help me.
Jim
My guess is there is something wrong with your video settings, but thats just a guess. Answer a few questions for me and we can try some stuff.

What is the last thing you see on the screen, exact is best, but general idea is ok.
What boot loader are you using, I asume GRUB, but just confirm for me.
What kind of video card are you using?
Exactly what version of Red Hat are you using?

Answer those and I will try to get you fixed.
aserty
The last thing I see is a bunch of things like,"Checking filesystems....OK" or "Iintiliazing module things" scrolling through for about 20 seconds then for just a fraction of a second at the very end it say,"Starting first boot" or something along those lines.

The boot loaderI'm using is GRUB.

My video card is a nVidia Geforce Something Something. (I can't remember exactly what it is, but it's 128 MB and I think either a 5400 or 5600)

When I go into the Linux OS selection screen it says that it's Linux Red Hat 2.4.20-8. I'm not sure if that's the numer you want or not though because the disk is a copy from one of my friends.
Jim
Ya, I am guess in is the NVIDIA card that is causing trouble.

Try this. Put in the first CD of your Red Hat Install ISOs and type Rescue at the prompt. Follow the menues till you can mount your file system. Mount it up and open the file /etc/inittab in an editor like emacs (emacs /etc/inittab) change the line
id:5:initdefault:
to
id:3:initdefault:

Save it [F10. f. s] and than reboot. If you can get a command line thats great. From there we should be able to edit the XF86Config file so that the device driver for you card is nv eventually we will need to install the nvidia drivers. But lets get a command line to start. If you can get that, your looking good.
aserty
I'm new at this so I don't know how to open up a file through the command line, the only commmand driven interface I've ever used is DOS and that was in very limited amounts.

Also, I'm running off of a Knoppix CD right now, and I was just wondering if it would be possible to run a program that is has to edit the stuff.

Thanks a lot.
Jim
great, Knoppix is perfect. Ok, do this.

You can do this through GUI or CLI, I will tell you the commands as you need them. Either open up the icon for you linux drive or mount it from the command line mount /dev/hda1 /mnt/hda1 you will have to be root to run the mount command.

Navigate to /etc and open the file inittab either from the gui or with the command emacs /etc/inittab

Edit the line, than save it F10, f, s. Now reboot the system. That should get you set. If you can get a command line, come back and I will tell you what to do next.
aserty
It won't let me save the file, it says that I should check to see if I have permission. I'm guessing that I have to log into root or something, which I do not know how to do.

Btw: The way I've logged into knoppix has always been by just hitting enter when the command line comes up.
Jim
In knoppix you can get root privilage just by typing the command su into the CLI. I am sorry, i should have told you that. In a regular system, where the root password is set, you would have to enter the root password to, but in knoppix, where they don't set the root password, you can just type su which by the way, if you didn't guess stands for superuser. Than you can do anything, because you are, the super user. (that should have been read with the dramtic pause and deep voice you know ....)
aserty
Alright, I typed in su and hit enter then I typed emacs 21 /etc/inittab and it opened up the file, so then I changed the 5 to a 3 and went to do save but when I did it said,"Save buffer?" and I clicked yes but it didn't copy over the original, it saved it elsewhere I think. So then I did it through the GUI and clicked on the file, opened it, edited it, and then it sid I wasn't allowed to save it. sad.gif
Jim
Wait, why did you type 21?

You can't do it from the GUI unless you have root privilage globaly in the GUI, unless there is some option if you right click to "Open as Root" or something like that.

Try this from the command line. Just type emacs to get the program open.

Than go open the file manually, either with the menus, or F10, f, o. Edit the line, and than save it. Make sure you saving it back to the same place.

Wile we are still screwing around here. Open the file /etc/X11/XF86Config and tell me what the driver is set as for your video device.
Robert83
Hi,

you could simply try logging in as root,

type vi /etc/inittab

type i and change 3 to 5

press ESC button

type :wq and press ENTER button

now

cd /etc/X11

cat XF86Config

search for the display driver section
and look for vesa or nv ...
and change it to nvidia
you can add these options under the nvidia line
Option NoLogo "1"
Option NvAGP "1"

Sincerely
Robert B
Jim
Robert is mostly right, but you can't just change it to nvidia with out actually installing the nvidia module. It doesn't come standard with any of the major distros. Thats why we are going to have to install it.
Robert83
whooops....


I thougth the module was already installed... smile.gif sorry

Sincerely
Robert B
Jim
We will let it slide this time, but next time you give faulty advice we will have to kick you off the forum. Sorry, thats just the way it is. Wait, sorry, thats not the policy, ok, you can stay.
aserty
Sorry, I was typing emacs 21 because the only editor I found under it was emacs 21. My mistake.

Alright, I did the first part of what Robert said and changed the five to a three, to get there through the CLI I typed:

su [enter]
vi emacs /etc/inittab

And I reopened it just to make sure the 3 was still there, and it was. But when I browsed to the file manually thru the GUI and opened it the three was still a five. So I'm not sure if it's changed or not.

I think the driver is "vesa," anyways, this is what is said about my video card:

Section "Device"
Identifier "Videocard0"
Driver "vesa"
VendorName "Videocard vendor"
BoardName "VESA driver (generic)"
EndSection
Jim
make sure you changing the mounted file system. Sorry, we didn't really make that clear. My bad, I am sorry. You need to be editing your file system, not the knoppix one. So that /etc but actually /mnt/hda1/etc or what ever your root file system is.

Sorry about that. So if your root file system is on hda1 you will need to mount it using the command mount /dev/hda1 /mnt/hda1 or usually knoppix puts icons for all your file systems on the desk top.

Sorry about that, we didn't really make it clear. You understand now? Your editing your system, not the temp system that Knoppix creates.

Your going to want your /mnt/hda1/etc/X11/XF86Config to have nv as the driver. Though vesa seems to be working your knoppix. Try nv though.
aserty
I did it thru emacs but it wouldn't let me so I did it the way Robert said and after I did :wq [enter] it said I needed to add a !, but I'm not sure where to add it too.
Jim
You need to make sure you have root privilage when your editing these files. If you don't have root privialage it wont let you change the file.

From the top, open up a console. Type in the command su to gain root access.

Change over to the /mnt folder cd /mnt make sure there is a place to mount your drive, if there isn't make it with the command mkdir hda1

Change into it, and go into it's /etc folder cd /mnt/hda1/etc

Open the inittab file in an editor, I know emacs so thats what I am going to use here emacs inittab if your in the folder, or emacs /mnt/hda1/etc/inittab

Change the 5 to a 3. And save it F10, f, s, enter check the file name as it goes, make sure its /mnt/hda1/etc/inittab and not just /etc/inittab.

Ounce you have changed it, reboot your system and see if you can get to a CLI log in, if you can, and can get logged in. From there we can do everything else.
aserty
Alright, I did what you said by tyipng this:


knoppix@ttyp0[knoppix]$ su
root@ttyp0[knoppix]# cd /mnt
root@ttyp0[mnt]# cd /mnt/hda1/etc
root@ttyp0[etc]# emacs inittab

Then if I try to edit it in emacs it says,"Buffer is read only."
Jim
What in the name of Linus is going on. Ok, let me boot up my knoppix disk and see if I run into the same problem.
aserty
Just so you know I'm using Knoppix version 3.3.
hughesjr
When booting redhat ... at the grub prompt ... highlight the kernel you are going to boot ...

Then press a

(this will enter append mode for grub)

Then press 3 and then Enter

You should then boot into run level 3 ...

Once in the console, you can follow the instrctions to change inittab to always boot to runlevel 3 (change the 5 to a 3 in the /etc/inittab line id:5:initdefault:)
hughesjr
Once you get in, you will need to install the NVIDIA drivers ... for now you can get the latest driver with this command from the command prompt:
CODE
wget http://download.nvidia.com/XFree86/Linux-x86/1.0-6111/NVIDIA-Linux-x86-1.0-6111-pkg1.run


You will also need to install (if not already installed) the kernel-source rpm for your current kernel. You said you have 2.4.20-8 ... which you need to upgrade (many security issues with that kernel).

I would upgrade it now (along with the kernel-source) before compiling the NVIDIA drivers ... Note: Every time you upgrade the kernel, you will also need to upgrade the kernel-source and recompile the nvidia drivers...

to upgrade it now, use these commands to get the latest RH9 kernel:

You didn't say what your processor is .. if it is AMD athlon, use this:
CODE
wget http://download.fedoralegacy.org/redhat/9/updates-testing/i386/kernel-2.4.20-35.9.legacy.athlon.rpm

If it is any kind of pentium greater than PII use this:
CODE
wget http://download.fedoralegacy.org/redhat/9/updates-testing/i386/kernel-2.4.20-35.9.legacy.i686.rpm


also download the kernel source (same for either Athlon or Pentium):
CODE
wget http://download.fedoralegacy.org/redhat/9/updates-testing/i386/kernel-source-2.4.20-35.9.legacy.i386.rpm


(in case any of the command wrap, they are the command wget followed by a space and the URL)

Once you have the latest kernel and kernel-source, issue the command:

rpm -Uvh kernel-2.4.20-35.9.legacy.i686.rpm kernel-source-2.4.20-35.9.legacy.i386.rpm
(for Pentium II or greater)

or

rpm -Uvh kernel-2.4.20-35.9.legacy.athlon.rpm kernel-source-2.4.20-35.9.legacy.i386.rpm
(for Athlon)
-----------
reboot ... select the new kernel (with the arrows ... don't hit enter, but use a) and add runlevel 3 with the a command at grub again...and in console mode

Now you can install the NVIDIA drivers:

go to the directory where you downloaded the NVIDIA file before...and make it executable:

chmod 755 NVIDIA-Linux-x86-1.0-6111-pkg1.run

then run it to install the new drivers:

IGNORE_CC_MISMATCH=YES ./NVIDIA-Linux-x86-1.0-6111-pkg1.run

After the driver compile completes, exit and edit the file /etc/X11/XF86Config and change the line:

Driver "vesa"

to

Driver "nvidia"

and remove any lines that say:

load "dri"

I would recommend once the graphics is working that you do all the updates here:
http://www.fedoralegacy.org/download/
----------------
Personally, since RH9 is not supported by RedHat any longer, I would recommend you use FedoraCore2 as your linux distro...
aserty
QUOTE (hughesjr @ Aug 26 2004, 06:00 AM)
When booting redhat ... at the grub prompt ... highlight the kernel you are going to boot ...

Then press a

(this will enter append mode for grub)

Then press 3 and then Enter
)

I did that, and after I pushed a it took me to a screen that listed some info about grub or something and then it said:

grub append 7 no root=label=/hdd=ide=scsi

But I typed 3 anyways and hit enter and it booted into the same screen as it always has.

Edit: Btw, I don't believe I mentoned this before, but my computer has two places to plug a monitor into, one is the video card and the other is directly into the mobo. I don't know how to tell my computer to use the one that's built into the mobo though.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.