Help - Search - Members - Calendar
Full Version: Suse 9.1 Bootloader Messed Up My Windows
Linuxhelp > Support > Technical Support
Kei-Kun
I installed Linux on the same harddrive as Windows I had put away like 19 gigs for it and it was unformatted and I just let Suse handle the Partioning thinking nothing was wrong but when I tried to boot to windows it said something like it couldnt find the operating system so I go the the recovery console and attemp to fix the MBR and then I reboot. Then when I get to the screen it says it cant find the an OS of any kind linux or Windows What should I do ? I want to avoid reformatting my HD cause I will lose a ton of things that I dont want to lose so could u ppl help me?

Thanks
Hemant
Suse-9.1 has some bug...if you have boot floppy...then you can use it to boot into linux and try fixing it...
Checkout this link...

http://portal.suse.com/sdb/en/2004/05/fhas..._booting91.html

if you don't have the boot floppy,then you can try to boot with installation CD..in recovery mode and try fixing up the MBR.
Jim
I will bet a lot of money that its a problem with your bootloader.

What kind of boot loader are you using? Grub or Lilo? Get yourself something you can boot up, like Knoppix or a linux rescue CD and boot that. Mount your linux drive and pull up your /boot/grub/grub.conf or /etc/lilo.conf depending on what your using. If you can't figure out what is wrong with your file than post it here along with the pring out from fdisk -l and I will help you figure it out.
piemann15
i had a similar problem with mandrake 10 but i could only boot in linux.
i was geting the error "ERROR LOADING OS" do you think that i installed incorrectly or a bootloader problem.
Cotuit
I'm having this problem too, and it has me in quite a panic. I really do need to get back into my Windows. I'm using SuSE Linux Personal 9.1 on a PentiumIII. My windows is XP.

I've gone here and not had any success, maybe someone can dumb down the directions for me.

[quote]http://portal.suse.com/sdb/en/2004/05/fhas..._booting91.html[/quote]

This is the error message I get when I try to load boot Windows:

[quote]root (hd0,0)
Filesystem tyoe is fat, partition type 0xc
chainloader +1

NTLDR is missing
Press any key to resart[/quote]

This "quick solution"...

[quote]Solution
One quick solution is to activate the LBA or large access mode under which the hard disk was previously addressed for the hard disks in the computer's BIOS. It is important that the hard disk values are not set to "AUTO".[/quote]

I don't understand what this means, what is it telling me to do? It looks like this is the preffered option, if someone can explain to me what it means and how to do it, I'd like to try it.

I've already tried burning the 'parted.iso' to disc, but I haven't been able to get the the point to try it.

[quote]- Insert the installation CD or DVD (important: on AMD64 systems, insert the 32-bit side of the DVD). Boot the CD or DVD up to the point where you can choose one of the different installation types.
- Press F6. A message will ask you to keep the driver update handy.[/quote]

I've inserted the disc and booted to the point where I can choose installation types and pressed F6 and nothing has happened. No message asks me about the driver update.

[quote]- Use the arrow key to select the menu item "Installation".
- Enter the boot parameter "fixpart=1" and press ENTER.[/quote]

I've chosen installation and typed in "fixpart=1" but it just continues to try to install Linux.

[quote]-When the message "Please choose the Driver Update medium" is displayed, remove the installation CD, insert the driver update CD you created, and press "OK".[/quote]

This message never comes up, it just starts going through a new installation.


I've been searching in various places to try to find a fix for this, and keep being lead to this one solution. Is there something else I can try if this doesn't work?

Thanks for any help anyone can provide.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.