Help - Search - Members - Calendar
Full Version: Errors Before Installation Even Begun!(screenshot)
Linuxhelp > Support > Technical Support
waj787
I'm a complete newbie to Linux but am curious so I thought I'd try it out. I downloaded Fedora Core and stuck the CD in and rebooted. It said to press enter to install so I did, then I see lines of garbage but then it just hangs. These are the last 6 lines:

NET4: Unix domain sockets 1.0/SMP for Linux 4.0
RAMDISK: Compressed image found at block 0
crc error <6> Freeing initrd memory: 2941k freed
EXT2-fs: Unable to read superblock
isofs_read_super: bread failed, dev=09:02, iso_blknum=16, block=32
Kernel panic: VFS: Unable to mount root fs on 09:02

I've done a bit of research and thought it may be my partitions so I played around with them a little. At first my intended Linux partition was the third on my single HDD (on master, there is no slave). But using Partition Magic I moved it back to the second and formatted it in EXT2. Here's a screenie:



I've tried "linux root=/dev/hda1" to hda6. There's a line further up that says something like "hda: hda1 hda2 <hda5 hda6>"... Don't know if that's any help.

I've tried removing that HDD and putting in an old 2.5GB. Freshly formatted it but still the same problem.

I've tried the CD in a different CDROM, same prob.

So far my Linux experience has been sh!t! Can't even get the damn thing to install. Any help is much appreciated.
waj787
Sorry I should have said I've got Windows XP installed on the first partition. But this probably has nothing to do with the problem because I've tried a different HDD?
lesio1974
you probably first create Linux partitions within Windows, using Partition Magic ("Install another Operating System" function, right?) and then try to install Linux on these partitions;

well, don't;

do not use Partition Magic to prepare partitions for Linux; as you can see it just does not work; use PM to shrink Windows, but leave the rest of disk unallocated, blank, do not create anything in that space using PM or partition commander or any windows application;

delete those Linux partitions, leave the space after windows unallocated, blank, unformatted and start Linux installation again;

Linux installer has partitioning tools included; use only Linux tools to create Linux partitions; just boot from Linux CD and you will get to the point where you can create and format partitions for Linux;

as it is now, PM will not help you through this, it actully makes things worse;

good luck

g
waj787
lesio1974 thanks for the help. I have also tried with the partition unformatted. But I have not tried the 2.5GB HDD unformatted, so that's next. Thanks again.
lesio1974
ok, maybe I misunderstood something, but you seem to be missing the whole point by saying "i tried with the partition unformatted"; the point is, DO NOT CREATE any partitons in the space where you want Linux installed; leave that space "UNALLOCATED"; if you create a partition, you are setting yourself to fail again, no matter whether the partition is formated or not, you do not want any Windows partitioning app to touch the blank, "UNALLOCATED" space meant for Linux;

believe me, I have been through your ordeal and unless you are partition table hacking wizard, you install will fail every time you try to put it on space that was partitioned from within Windows;

good luck

g
michaelk
FYI you should not post the same thread in more then one forum. Maybe an admin will combine these togther.
http://www.linuxhelp.ca/forums/index.php?a...t=ST&f=3&t=4555

How far does the install go. Do you see any messages on finding hardware, language selection or anything else? You can switch between displays by pressing alt-f1 thru alt-f6. There might be other error messages that could be important.
waj787
Sorry about posting the same thread!

lesio, sorry I didn't get you first time... I'll try with the space unallocated. Did you used to get the same sort of problem then?

michaelk, the install doesn't even begin! I put the CD in, reboot the PC and I've set it to boot from CD first so then I get 3 options. I think they were:

1. Upgrade/install in graphic mode (Press enter)
2. Upgrade/install in text mode (*some command I can't remember*)
3. Help (or something)

So I press enter and I get these lines of writing like its loading or something. Some of it is to do with hardware yes - it detects my HDD, CDROM, DVDROM, then a few move lines and then it just hangs. And the last 6 lines are the ones I previously posted. So it doesn't even get to the beginning of the installation.

But anyway, I'll try with unallocated space and see how that goes. Cheers for your help guys, much appreciated.
michaelk
What is the make / model of your computer?
Post the hardware specs of your PC.
This looks like a memory problem.

http://www.geocities.com/rlcomp_1999/memory.html
lesio1974
yes I got exactly the same problem on my very first Linux installation (Fedora Core 1), after using PM to make the Linux partitions; it took a while to figure out what was going on but after a few failures, I decided to use PM just for shrinking Windows withour preparing the Linux partitions; it was a bit scary, as I was expecting Linux partitioning tools to be command-line only, but to my surprise, a nice, graphical partitioner started that was very easy to figure out and set up; the rest of install went smoothly;

then there were some trouble with setting dual-boot (XP/Core1) but this is another story;

just keep posting here if yo run into any trouble;

good luck

g
waj787
OK it didn't work with the space being unallocated either. It was set up like this:



I asked a couple of Unix nerds (tongue.gif) at work today and they thought the CD might be duff. So I'm going to try one of their CDs and see if that makes any difference. I'm starting to think if all this hassle is even worth it!
waj787
Sorry, my specs:

Athlon XP 1800+
MSI KT333 Ultra-ARU
256MB Samsung Original
Inno3D GeForce4 Ti4200
120GB Maxtor DM+9
Samsung DVD ROM
Cyberdrive CDRW

(I know I need to upgrade!)

michaelk, I've tried telling it how much RAM I have, it didn't change anything sad.gif
waj787
OK the problem is sorted now. There was nothing wrong with the partitions, it was a duff copy! Tried a mates CD and that worked fine blink.gif Thanks for the help, I'm sure I'll be on here again very soon with other Linux problems! tongue.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.