Help - Search - Members - Calendar
Full Version: System Doesnt Boot!
Linuxhelp > Support > Technical Support
azul79
hey!
i' ve a slack 9.0 with 2.4.20 kernel v.
i installed v2.4.27
i first followed the kernenewbies guide. but then i did what slackware essentials book said..
none of them worked..
when i reboot my pc.. and get into the lilo.. and select to boot the new kernel.. it enters into a lilo loop..
it reboots again.. and ask again which kernel i want ..
i dont know what can be happenning..
i'm new in this,.so is anybody can help me.. PLEASE!!
unsure.gif

thks!!
Jim
Well first off, can you select your old kernel still and get in to your system that way? If you can, boot up and loot at a few things for me. Well, I guess first, how did you install the kernel source or packet?

Next, exactly what do you mean by a lilo loop? Does it ever try to boot the kernel? I would check your lilo.conf file you can find it at /etc/lilo.conf look at make sure that the options are correct and that it points to the right images in your /boot folder.

Lets start there and see what happens.
azul79
THANKS FOR ANSWER!!
yes i can select my old kernel and get into my system..
the instalation i did this way:
- i downloaded the sources from ftp://ftp.kernel.org/pub/linux/kernel/v2.4
then i followed the lkernelnewbies guide to compile a kernel.. it says this:
- bzip2 -dc linux-2.4.0.tar.bz2 | tar xvf -
- make menuconfig
- make dep
- make bzImage
- make modules
- make modules_install
- cp arch/i386/boot/bzImage /boot/vmlinuz-2.4.27
- cp System.map /boot/System.map-2.4.27
- edit /etc/lilo.conf, and add these lines...
image = /boot/vmlinuz-2.4.27
label = 2.4.27
root=/dev/hda3
- run /sbin/lilo

that is what i did.. then i rebooted and selected the new kernel.. and instead of loading it.. it rebooted again and entered into the lilo again..
i did a couple of times.. and it was always the same thing.. so i selected my old kernel and that way it worked..

then.. someone told me that with slack u dont need to do
make modules_install
and so i followed what ' slack essentials book' said..
so i did this:

- cd /usr/src/linux
- make mrproper
- make menuconfig
- make dep
- make clean
- make bzImage
- make modules
and then ..
run the lilo again--

do u think is a hardware problem?

here is my lilo.con file

image = /boot/vmlinuz
root = /dev/hda3
label = Linux
read-only
image = /boot/vmlinuz-2.4.27
label = 2.4.27
root = /dev/hda3
read-only

thank u very very much for helping me!!
Jim
No, I don't think its a hardware issue, I just think you didn't get the kernel compiled correctly, its a tough thing to do. Did you try to following the commands that the Slack Essentials Book gave you, because those should work. Delete your first try from /boot and delete your unpacked source, and start clean again with a fresh unpack, see where that gets you.
azul79
thank u!!
i' ll do it and let u know!
thanks!!
azul79
hey!
i unpacked 2.4.26 v to see if it was a version problem.
but nop
it happens the same thing..
i think it might be a link problem..

what i di after all the installs is this:

cp arch/i386/boot/bzImage /boot/vmlinuz-2.4.27
cp System.map /boot/System.map-2.4.27
and then edit lilo and run it
/sbin/lilo -C /etc/lilo.conf

i dont find the problem sad.gif
azul79
i read on a page..
http://www.linuxelectrons.com/article.php?...004013006062220

that it is necessary to uncomment my Makefile

Next open up '/usr/src/linux/Makefile'
Uncomment the line...
#export INSTALL_PATH=/boot
To read:

export INSTALL_PATH=/boot

is this necessary? is the first time i read this..
the Slack esential books says anything about it..
unsure.gif
Jim
Thats the same as doing the cp command that you have been doing, it just saves you a step. Six of one, half dozen of the other kind of thing. I am a little stumped on this issue. How are you configuring the kernel? That could be the problem.

If anyone else wants to jump in here I could use the help.
azul79
hey!
i really appreciate your help!! really thanks!!
what do u mean by..

" How are you configuring the kernel? "

do u mean what i do @menuconfig?
i tried to set most of the things.. just in case..

the strangest thing (@least for me.. ) is that i dont get to have an errror message... it would seem as an image path problem... i dont know! sad.gif
i' m getting crazy with this! huh.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.