Help - Search - Members - Calendar
Full Version: Installation Problems
Linuxhelp > Support > Technical Support
Dinero
It took me forever to understand what it is I need to do in order to install one simple piece of software: bluefish. I finally figured out about the terminal to enter in commands and ect. But, right when it all starts to work out I get this little error message

"Installation Error: Compiler or configure file cannot create executables"

Its pissin me off so much... WHAT DO I NEED TO DO!
Dinero
Can no one help me with this problem?
Jim
what commands did you run? I don't know exactly what the deal is with bluefish, but if its like 90% of the rest of binary installs out there you need these three commands

./configure
make
make install


You probably didn' run ./configure, try that and see what happens.
michaelk
With out the rest of the error messages my first assumption would be that the compiler is not installed. BTW what distribution are you running? You will need to install the development package. Without knowing the distribution I can not say how to accomplish the task.
Dinero
I'm using SUSE.

It was the ./configure command I was using when it presented the error. Later I found out about CHMOD and fixed it for the configure file, but then the error message read "Installation Error: C Compiler cannot create executables." I still don't know what the problem is.
hughesjr
You didn't say which version of SuSE you are using (9.0 pro, 9.1 pro, 9.1 personal, etc.) ... but in SuSE 9.1 professional, bluefish is an RPM available on the CDs.

Use YaST to install bluefish.

Juat as a side note, if possible you should always use the rpms provided with a distro ... and any updates that distro provides for your packages. The distros do things to make programs work together ... and controll versioning information ... with their default installers.

Building from source (and not installing from RPM) will prevent an entry in the RPM database for a given program, so any other programs that depend on the first program won't install. So if available, use an RPM for install.
Dinero
I'm using SUSE Personal 9.1. In order to install Bluefish I need to install GTK+ 2.2 and that is not a .rpm file. I unpacked what I need to install GTK and read the installation instructions which said to use the terminal and the ./configure, make, make install commands. After I enter the ./configure command it tells me of the error. I've tried using make after that but it won't work. I've tried looking how to install things from YAST but it doesn't have an interface I understand. I've been following the installation instructions from the files I'm getting. And isn't YAST only for .rpms?
hughesjr
YaST is only for installing RPMS ... correct.

As a general rule, you should only use RPMs on a distro that provides them.

RPM stands for RedHat Package Manager ... and there is an RPM database that contains the version and name of all RPMs that are installed.

So if you installed a gtk 2.2 RPM ... all programs that need that RPM can see that it is installed.

I don't recommend that people install programs from source unless absolutely necessary ... because the RPM database is not updated and you are then stuck installing and maintaining half of your programs from source and the other half from RPMs.

Also, installing gtk2.2 from source might overwrite already installed gtk 2.4 or 2.0 if it is already installed ... rendering some installed software useless.
-----------
SuSE 9.1 personal is a subset of SuSE 9.1 professional ... and 9.1 professional. If at all possible, I would recommend 9.1 professional OR FedoraCore 2 OR Mandrake 10.
----------
None of that really helps you right now ... I don't have SuSE 9.1 personal installed because it just doesn't provide enough fo rme to get work accomplished ... here is a link tht recommends downloading the SUSE 9.1 professional gcc and supporting software:
http://www.linuxquestions.org/questions/sh...threadid=213620

Pesonally, I would recommend that you just install SUSE 9.1 Professional and use YaST to install bluefish.
Dinero
Do you think that I probably already have GTK (any version) on my machine, and if you don't know, how would I be able to check and see? If it is, then I won't have to worry about a lot of that stuff. I think that I'm going to buy or download Red Hat to use, do you think that'd be a better idea?
adam.stokes
Download Fedora! smile.gif
hughesjr
I would recommend either Fedora Core 2 or Mandrake 10 for install (take your pick). I personally use Fedora Core 2 on my daughter's computer (although I use Gentoo on my Workstation). SuSE 9.1 professional is good as well (but I don't like the FTP install).

I think I would personally recommmend Fedora Core 2.

----------------------

If you have Gnome installed, you have gtk2 as well ... if you don't have Gnome, it is possible that gtk2 is not installed.

To see if gtk is installed do the command:

rpm -qa | grep gtk2

My result on a SuSE 9.1 Professional test install is:

gtk2-2.2.4-121
gtk2-engines-2.2.0-393
gtk2-themes-0.1-634


------------------------------
If you choose Fedora Core 2 ... you can get bluefish from here:
http://tettnang.freshrpms.net/rpm.html?id=30
Dinero
Thank you very much. I apreciate you helping me with my problem.
Dinero
Man, I downloaded all of the Fedora project for DVD and burned it on a one time DVD disc (4.7 GB) and it turned out it wasn't compatible with my motherboard and try the second version available. I waited some 6 more hours to download that and there was an error at the end and the whole file couldn't download.

I'm gonna try to fix my little problem before I try to download that whole thing again. I've been looking on google and stuff for help to this and apparently there are a lot of problems... If anyone has any express information that can help, it would be appreciated, if not, thanks anyway. You've all been a help to some newbie to linux.
Dinero
Hey guys, I've got another problem here: http://www.linuxhelp.ca/forums/index.php?a...87864e0ca5c77b5

Any ideas?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.