Help - Search - Members - Calendar
Full Version: Urgent Corel Help Needed!
Linuxhelp > Support > Technical Support
okay, I'm a linux virgin, and it seems that without some help, I may remain so for awhile. when working at a computer store, the corel vendor gave me a copy of the first release of corel linux (as was the habbit of vendors). so for the next few years, it had only been gathering dust in my software library, owing to the fact that I have a lot of top of the line (or was at various points), and none for linux. anyway, I got this fifty dollar computer from someone (dell, pIII 866, 128 megs ram, 20 gig hdd), so I decided I might as well see what all the linux fuss was about.

so after an astonishingly easy install, I go to run it and I get a flickering screen (flashes on once a second for a brief flash, and you can only type crap in for those miliseconds it's on), and no GUI (being a windows simpleton, I don't know command lines beyond the basic theory of what they do)

so if anyone can help me get this working, I would appreciate it.

p.s. one of the reasons for putting linux on this machine is that I am trying to see if linux is or is not ready for prime time, just in order to be more knowledgable in conversations on the subject. so what I'm doing is trying to fix this box up for linux and give it to my mom. if she can use it, then linux is indeed everything the linux intelegensia claims it to be. to put it another way: prove it!
Well first off if you want me to prove it to you, go get a current version of linux. Its only been in the past few years that Linux programers have really tried to take advantage of the domestic market. So if you want to give something to your mother, got get Mandrake 10 or something of the like. If you want to see why all the power users, sever admins, and programers love linux go get yourself a copy of Gentoo or a Red Hat Enterprise Linux clone (RHEL). As for you current perdiciment, your just need to configure your video settings.

First off, I need to know a little bit more, you have a command line correct? You don't have a gui. Give me a few things. Tell me what the video card is or if its onboard, and if its onboard I need to know on what board. I need the error report from the command startx and than I need to see whats inside your XF86Config file. cd over to /etc/X11/ and open the file XF86Config with an editor like emacs of vi (emacs XF86Config) and show me what is in there. Its a pretty long file so you will want to do one of two things, either copy it down to a disk of some sort, or just copy out the section that is the same as the error code. If the error is "No Screens Found" give me the screen section or what ever.

If you can't figure that out, come back and I will try to give you more help. But you should be able to do that. At least get me the video info and the error message.
the video is onboard. the model of the motherboard didn't jump out at me, so I took down all the numbers that looked pertinent, and ran them through google, with non-specific results.

here's what I took down:

dell rev. a04 (visually this apeared to be the most likely candidate for the model, but google only gave one entry, that of a forum post by someone trying to find out what his motherboard was. mine isn't the same, as the other numbers were different, and the replies to his post told him that his was an early pII board, and mine is a pIII)

chipset: intel 810, fw82810e

aa a01025-310


I hope this helps, but I'm not sure that it will.
The chip set info is good enough. I am suprised that your version of linux didn't include the generic driver for intel chip sets, but thats what you get for using old distros.

Here, this should do it for you
that didn't appear to relate to my problem, but what do I know, so I tried it and am balder for my efforts. see, when I try to run Corel Linux (option 1 of a five option menu that loads before anything else, and also includes VGA Mode, Console, Debug, and Expert) I get a strobe (which I think is a better description of what I'm experiencing than I previously supplied) that makes it virtually impossible to enter a password, and extremely difficult to type in anything else.

the reason is that, only for the brief moment that the text is on the screen does the keyboard work. if I type when the screen is black, then nothing will have been changed when it strobes back on. so split-second timing is required to enter a simple command, and since the password doesn't display any indication of what you've typed, you have no way of knowing if your aim was true.

and not knowing the commands and the grammer of linux, I'm all the more lost.

so anyway, when I try the other options in that original list, the all give me this (at the end of a long string of cryptic messages that would seem to indicate loading of one thing or another): "/dev/hda2 was not cleanly unmounted. check forced", except for the expert option, which gives me "lilo boot:", and that doesn't seem to lead anywhere that I need to go (although it does get me back to "/dev/hda2 was not cleanly unmounted. check forced" depending on what I do)

anyway, the instructions of the intel site bear no relation to what I can see or do in the command line structure. and the files, well, how am I supposed to load it from the CD rom or FDD given these circumstances?
update: I found that if I went to vga mode, and just waited, then it would run through a bunch of stuff that takes forever until finally getting to a GUI (a safe-mode kind of GUI, but it's a start) from there I can get that driver installed, except that the instructions from intel still seem to be unrelated to anything I can find there. also, my keyboard wasn't working in that mode.
Just our of ceriousity, have you tested this system with an OS you know? Because I am not entierly convinced there isn't a hardware defect.

Secondly, is there any real reason why your so interested in Corel Linux? Like I said earlier, its pretty out of date, if you really want to see what linux is like, download some new iso files and install Mandrake or Fedora or something. You could even get a live CD like knoppix and see what linux is like without installing anything right away. I am not trying to dodge your problem, but Corel linux is out of date, buggy, and obsolete. If you really want to know if linux is "ready for primetime" at least give it a chance to show off its best side, you wouldn't go judge windows by ME so don't judge linux based on an older distro.

If you really want to fix this system. But the first CD back in and get into the rescue shell (there should be instructions) It will alow you to mount your hard drive and have access to the files. I am guess the problem is with the framebuffer. I want you to do two things wile your in the rescue shell.

First open the file /etc/inittab in an editor like emacs (emacs /etc/inittab) change the line

Save it (F10;f;s) and now open your lilo.conf file (emacs /etc/lilo.conf) There should only be one or two entries. Look for anything with the word vga in it if its there, copy the line down and show it to me, if it isn't tell me that. After you reboot your machine it should go into a command line only interface. From there we can try to install the video driver.
the reason I want to use this linux is that, well, I have this linux. I'm very anal-retentive when it comes to unused software. if I have it, I simply must try it out at some point. the only reason this has sat of the shelf for years is that I haven't had a good excuse until now.

anyway, the computer came with windows xp already installed, which would have been fine, and for the most part was running smooth. except, it had some anoying spyware that prevented browsers from functioning (tried three, including explorer), and that I could not remove. since internet is basically all this computer was gonna be used for, that would not do. so I figured I'd try and get the linux to work, and see what it was like, before resorting to installing windows SE (which is the only version of windows I have).

so I'll try that stuff, and yes, there is a good chance that I'll just break down and get mandrake 10 at some point, but why hurry?
Alight, that makes sense to me, I was just trying to understand your motivation. A challenge is always good. Let me know what happens.
The problem with corel linux is that it no longer exists (they have stopped all developement) ... it would be like trying to install Windows 95 (or Windows 3.1) to see why everyone is saying they like Windows XP.

The kernel, hardware detection, svga support, ect. from Corel Linux is not going to be very good since it is based on an older version of the kernel.

Your machine is good for Linux (except it needs a little more RAM ... 256mb would be great).

Corel Linux is not the same as RedHat Linux or Mandrake Linux ... it was based on Debian GNU/Linux.

Linux really refers just to the kernel ... and the whole OS is really a Kernel and a lot of programs. Each of the programs (XFree86 for the GUI X-windows client, for an office product, Mozilla for your web browser, etc.) are seperate items. Since Corel is no longer in business (for Linux) there are no upgrades for any of the software ... so you really don't get to see Linux now ... but Linux 4 years ago.

Jim's recommendation is a good one ... get a new version of GNU Linux ... like Mandrake 10 or FedoraCore2 ... and not a version by a vendor who is no longer in business.

(Just my opinion smile.gif)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.