Help - Search - Members - Calendar
Full Version: I Hate It When The Change Things....
Linuxhelp > Support > Technical Support
Jim
Ok, so I tried to rebuilt gentoo so it would run a little better. Got through the build and now I am trying to install the stuff to make it a good workstation, X11 KDE that sort of stuff.

So I am following along with the desktop guide, and it says run emerge xorg-x11

So what does that install? Because none of the config files I am used to are there. I get errors if I try to run startx but there is no XF86Config file to edit. The settings are stored in the xorg.conf file and it looks like the same thing, but I just want my standard XF86Config back. Whats going on here? Somebody want to explain this change or what I did wrong?
hughesjr
xorg.conf is the same as XF86Config ... it uses the same commands. If you still have your old XF86Config, you can use that.
-----

Here is the lowdown:

XFree86 changed their license (starting with version 4.4.0) to require a lot of new credits to be written in documentation for distros, and the new license requires specific permission to mention XFree86 in ads, etc. The FSF said the new license was not compatible with the GPL. This caused several distros (Fedora, Mandrake, Gentoo, Slackware) to switch to X.org's software ... which is a fork from XFree86 from before the licensing change.

Debian and SUSE still use XFree86 in their latest releases ... but they use version 4.3.x ... not version 4.4.x.

A quote from Debian:
Many OS distributors, including Debian, have resolved to not distribute any version of the XFree86 codebase using the new license.

A quote from SUSE:
SUSE LINUX does not endorse the XFree86 project's recent license changes. Hence, SUSE will not include versions of XFree86 subject to the project's modified license in future SUSE product offerings.

So both SUSE and Debian will also not use XFree86 on any new releases in the future ...
----------------
SO ... it's time to learn about X.org smile.gif
Jim
Ok, so I finally got around to trying to get xorg working. So I used my old XF86Config file because messing with the dual monitor thing is messy and I had it working well. So it errored out, no suprise. Narrowed it down to a problem with the Files Section, so I just commented the whole thing out. Now I have a X enviroment but my moust wont work.

I tried cat /dev/psaux and cat /dev/mouse and got nothing, not a single blip. So I am a little confused as to where my mouse is comming in. Any ideas? Here is the Device section from my xorg.conf file

CODE
Section "InputDevice"
       Identifier   "Mouse0"
       Driver       "mouse"
       Option       "Protocol" "auto"
       Option       "Device" "/dev/psaux"
EndSection


I have tried it with /dev/mouse to and that didn't work either. What next?
hughesjr
Sorry ... I've been busy lately smile.gif

As root (from the console with no display manager running) try running the command:

Xorg -configure

In your /root directory, you should have a new file named:

xorg.conf.new

It will have all the detected information ... which should contain the mouse info. You should be able to cut and paste the mouse info into your current file.

One place to try is:
Option "Device" "/dev/input/mice"
Jim
That's what I had the first time and it gave me a "can not find" error. I can try it agian when I get home from work, but I don't think that will do it.
Jim
Ya, that didn't do it, so I am still really confused. I haven't had enough time to play with it but if you could help narrow down the problems that would be great.
Jim
Ok, here you go Hughes.

I tried Xorg -config and used the exact mouse settings, didn't work.

I found that if I run cat /dev/mouse or cat /dev/pauxs before the x server starts up than I get stuff from my mouse, both of them, but after the xorg server starts up, I get nothing.

I think something got screwed up with my modules when I did the install, I don't really think they are either a) where they are suposed to be or cool.gif have the right privilages to access them. Either way, something is screwed up with the modules. So how do I rebuild my modules and see what happens?

I did an emerge sycn and a emerge --update system and even an emerge world and it still isn't working. So thats where its at.
hughesjr
so from the console you have mouse input ... but from X you have nothing?

I would first make sure I was running hotplug ...

ls -al /etc/runlevels/default/hotplug

output should look something like this:

lrwxrwxrwx 1 root root 19 Mar 12 07:49 /etc/runlevels/default/hotplug -> /etc/init.d/hotplug

If you don't have hotplug in /etc/runlevels/default, make sure it is installed by doing:

ls -al /etc/init.d/hotplug

output should look something like this:

-rwxr-xr-x 1 root root 843 Apr 6 18:18 /etc/init.d/hotplug

If you don't have hotplug installed, install it:

emerge hotplug

If you have hotplug installed, but not in /etc/runlevels/default (which means it starts every startup), do this to add hotplug to start during the default runlevel with this command:

rc-update add hotplug default

If you had to do any of that, start hotplug with the command:

/etc/init.d/hotplug start

Then startx

----------------------------------------

If that doesn't work, I would try to re-emerge xorg, like this:

emerge -D xorg-x11
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.