Help - Search - Members - Calendar
Full Version: Teensy Console
Linuxhelp > Support > Technical Support
paulcox
I've come a long ways teaching myself Slackware from square one without having to bother the online community with newbie questions, but it's finally got me stumped on this one small issue. I'm running Slack 10 with the 2.6.7 kernel on a Dell Inspiron 8100 laptop. Most of my woes stem from my ATI Mobility Radeon 7500, a horrible Linux card by all accounts. I've got it on speaking terms with X to the extent that I can run KDE at 1600x1200x24, but I've pretty much given up on direct rendering.

My current problem came when I tried out the lid button support after setting up ACPI. It didn't work, the screen just wouldn't turn back on. Not a big deal, I don't really need that feature anyway. But after rebooting, the console wasn't rendering right. It's still 1024x768 pixels (or whatever lilo.conf tells it to be) but instead of stretching to fill the screen those pixels all stay in a box in the middle of an empty 1600x1200 field, making the characters barely legible to the naked eye. This is the case right from the first stage of booting, when the annoying Dell logo pops up.

I crudely tried to make it revert by removing 1600x1200 support from xorg.conf, and even closing the lid and crashing the display again, but it's still tiny. Any ideas? I'd like to be able to use lynx without going blind.
Jim
I think that thats a BIOS thing with dell lap tops. I was working on my girlfriends Dell Inspiron in windows and when you reboot into safemode it does the same thing.

I don't think the problem is so much on the linux side as on the Dell side. I think its a big screw up in dells design. Now, if you had it working before, than there is obviously a way around it, and if you feed it the right frambuffer info on start up it might work. I hate lilo, so I can't really tell you how to do it. But somebody else might, or go look up frame buffer stuff for lilo and see if you can get that to help you.
paulcox
Thanks Jim, once I realized it was a Dell thing I looked around for Linux-on-Inspiron guides and found the (embarrassingly simple) answer. For future reference, just hit Fn+F7 to switch display modes. Problem solved!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.