Help - Search - Members - Calendar
Full Version: Dhcp Server
Linuxhelp > Support > Technical Support
imaginaxion
Hi
Iíve just started using linux for the first time and will be using it for a server and internet firewall router etc etc
Iím running mandrake 10 and itís been a great first impression. smile.gif
I have looked in the linux section on how to set up dhcp but being new Iím still not 100% sure what is going on.
I think I have most the stuff setup eg the dhcpd.conf but when I try start the dhcp service it just sais failed
Does anybody know what the prob might be or could go through a step by step procedure of getting it set up
thanks
hughesjr
Here is an example (not mandrake 10):
http://www.linuxhelp.ca/forums/index.php?a...=ST&f=15&t=4052

And here is another howto:
http://ldp.hughesjr.com/HOWTO/DHCP/x369.html
(see section 4.3)
imaginaxion
i have already followed the first link and completed all that. i will try the second and see if that makes a difference when i get home. The thing is the actual dhcpd service won't start i have also set it to start at boot but fails everytime.
i'll let u know the result after i try the second link.
michaelk
Check the logs /var/log/messages for a clue.
NodMercinary
I dont have the dhcpd service.. does anyone know where I can DL it for redhat 9?
imaginaxion
NodMercinary, you can download from http://rpmfind.net/linux/RPM/ just do a search for "dhcp 3" and u will find one for your dstro

i have followed all the instruction and it is working YAY although only when i start it in the shell.
the thing is when i went into the services through the gui to turn on dhcp at boot i noticed that it sais dhcpd is stopped and it just fails when i try start it(even though it is running from the shell). why is this?
i did try installing a dhcp rpm, could this cause the prob as it is using the rpm package instead of the package that came with mandrake.(i did this before i new mandrake already had one :-
if that is so what can i do to resolve it.
also need to know how to start dhcp at boot

thanks ppl for the help so far smile.gif
hughesjr
try:

chkconfig 016 dhcpd off
chkconfig 2345 dhcpd on

Then:

chkconfig --list | grep dhcpd

(it might be dhcp instead of dhcpd ... I am not near a Linux PC right now).
imaginaxion
hughesjr it was dhcpd.
i did that and got the result:

dhcpd 0:off 1:off 2:on 3:on 4:on 5:on 6:off


i dont know what that means and doesn't seem to have solved the prob
imaginaxion
here is a little more info that may help you help me

i can only start the dhcpd by typing /usr/sbin/dhcpd
if i use service dhcpd start it resonds with failed

i can stop it using service dhcpd stop thou,
or using service dhcpd restart it stops dhcpd (if already running) but fails on restart
hughesjr
dhcpd 0:off 1:off 2:on 3:on 4:on 5:on 6:off ... that means that runlevel 0 (going to shutdown), runlevel 1 (single user mode), and runlevel 6 (going to reboot) will cause dhcpd to shutdown .... and dhcpd should start during runlevel 2,4 (user defined run levels), runlevel 3 (console), and runlevel 5 (gui).
----------------------------------

What happens with the command:

/etc/init.d/dhcpd start

(it probably fails...)

I would say there is a problem with the startup script ... get the latest dhcpd rpms from here for mandrake 10 ...

http://sluglug.ucsc.edu/pub/Mandrakelinux/...ates/10.0/RPMS/
NodMercinary
ok I installed the whole dhcp 3 deal and got the dhcpd.conf file, and I edited the /etc/sysconfig/dhcpd file to eth0... but it still says Not configured to listen to any interfaces... says I have no subnet declaration for eth0... blink.gif
NodMercinary
nvm, fixed it, thanx :-D
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.