Help - Search - Members - Calendar
Full Version: Need Help Mounting My Windows Drive
Linuxhelp > Support > Technical Support
purdude87
i'd like to have access to my files on my windows drive, but i'm having some trouble.

i created a directory
mkdir /mnt/windows

then i tried
mount -t vfat /dev/hda1 /mnt/windows

and got this error...
mount: wrong fs type, bad option, bad superblock on /dev/hda1,
or too many mounted file systems

here's what my drives look like...

fdisk -l

Disk /dev/hda: 255 heads, 63 sectors, 7297 cylinders
Units = cylinders of 16065 * 512 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 7297 58613121 c Win95 FAT32 (LBA)

Disk /dev/hdb: 255 heads, 63 sectors, 1021 cylinders
Units = cylinders of 16065 * 512 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 13 104391 83 Linux
/dev/hdb2 14 669 5269320 83 Linux
/dev/hdb3 670 734 522112+ 82 Linux swap
/dev/hdb4 735 1021 2305327+ 7 HPFS/NTFS


Shouldn't this be working??
chrisw
you are getting that error because your windows
partition is not vfat...it is NTFS
purdude87
i do have a ntfs partition on my second hard drive just for backing up files, but my main windows partition, and the one i'm trying to mount, is fat32 and is on hda1
chrisw
ok....overlooked the other drive

when you are mounting your drive

leave off the -t vfat and see what happens
i usually when mounting a windows drive
just type the following

mount /dev/hda* /mnt/windows

that usually mounts it well

i of course replace the * with the correct number needed
michaelk
Yes it should work
What distro / version are you using? Mandrake setups all filesystems during the install process.
The mount command with no options will display all mounted filesystems.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.