Help - Search - Members - Calendar
Full Version: Can't Boot Anymore "l 9a 9a 9a"
Linuxhelp > Support > Technical Support
nadim khemir
So I was gently working on a perl module when a gaming fever got me. I could get CS to install on one of my windows box so I thought I'd reboot my linux box (I have a dual booot) to try to install it there. Fatal mistake!

Some details:
A rather moder P4 box with Mandrake10.0 and WinXP.
Never had much problems before.
Thought I had installled GRUB!

The problem:
I can't boot no more.

What I've done so far:
Search the net for hours.
Tryed the rescue mode, reinstalled the boot loader in 10 different ways
mounted the drives, chrooted, ran lilo -v -C /etc/lilo.conf
Tried again and again in different ways.

I simple words, I'm stuck. I first can't understand how this can happend! Second I don't know how to fix it.

Someone knowladgable please help or point at something I can read and do.

Cheers, Nadim.
There is a 2.6 Kernel bug that happens on some computers because of the way the partition table is created:

But that normally allows Mandrake to boot, and has the XP boot broken.

One thing you can try (to get a bootable system) is boot from the WinXP CD, go into the repair console and use the fixmbr command ... see this thread for links to the Microsoft help site.

If that gets XP working, you can reinstall Mandrake and install the bootloader to the root partition (and not MBR) ... then use BootPart following these instructions
nadim khemir
Hi, Thank you for your answer. I'll check the link.

The problem is fixed. Here is the link for those that might get into similar problems.

Cheers, Nadim.
Now that it is working, obviously don't change anything.

I had assumed that you had already done lilo -v from the CD boot (with boot=/dev/hda) and it wasn't working ...

I am also not sure what happened to your install.

Setting boot to /dev/hda will have lilo reinstalled to the MBR when you use lilo -v ... which in your case worked.

On some BIOSes, this doesn't work because there is a geometry issue between linux and windows (which was the bug I posted)... you seem not to have that problem.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.