Help - Search - Members - Calendar
Full Version: Sorta Newbie
Linuxhelp > Support > Technical Support
OK, So I'm not TRULY a newbie in that I have a degree in CS and have a lot of experience with UNIX. HOWEVER, still need a little help.

Got Linux Mandrake 10.0 with KDE installed, dual booting with XP Pro, and I've got my wireless network working. However, I must run the following script as root (either by logging in, or using su) - " home". Is there a way I can set it up so it runs it on bootup of linux and/or KDE? This way, I don't have to bother with it, and my wireless network is working when I login to KDE?
hi hope this is helpful,

(1) Checked that you have enabled the PCMCIA service on startup.
KMenu -> System Settings -> Server Settings -> Services
make sure there's a tick besides the pcmcia service box.

(2) You're using wireless nic, so i assume it should be eth1, vi /etc/sysconfig/network-scripts/ifcfg-eth1
make sure ONBOOT=yes

(3) Or you can run your script " home" in /etc/rc.d/rc.local that's the last script that will be executed when linux boots up.

You can do this to make it run as well:

edit the file /etc/rc.d/rc.local and put this in the bottom of the file:

full_path_to/ home

You might also need to make sure that a PATH statement is near the top of either or rc.local that has at least this:


If you need to run this as a user other than root from rc.local (for a driver you probably need to be root, and this is not applicable, but just for info) it would be like this:

su - username -c "full_path_to/ home"
That worked exactly how I wanted it to, thanks for the help!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.