Help - Search - Members - Calendar
Full Version: Noob Question. Mounting Fat Drive For User
Linuxhelp > Support > Technical Support
heylan
Dear all,

Noob question again. I can't get my user accounts to read a FAT32 drive.

I've tried changing the permissions on the /mnt/windoze directory but it doesn't change anything at all (any idea why?). It shows rwxr--r-- for the drive. However, if I unmount the drive, the permission goes to rwxr-xr-x. Why is this so?

My second step is to edit the fstab file. Instead of default, I replaced it with noauto,users,exec,dev,suid. Then I logged in with the user account and tried to mount it - says 'only root can mount'.

So basically, I'm stuck. Should be an easy problem for you guys.

Any help is greatly appreciated.

Thanks! wink.gif
lesio1974
try replacing "defaults" with "umask=0000" in your fstab;

my fstab line for the FAT32 partition looks like this:

CODE
/dev/hdb6               /linwin                 vfat    umask=0000        0 0


and it works fine

good luck

g
hughesjr
OR

Use auto instead of noauto ... and and maybe do this (which will mount the partition when you boot the PC):
CODE
/dev/hdb6               /linwin                 vfat    auto,defaults,umask=0000        0 0


I used lesio1974's eaxmple ... obviously, you would use your device and mount point
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.