Help - Search - Members - Calendar
Full Version: Problem With 1.5mbps Internet Connection
Linuxhelp > Support > Technical Support
feef
Hi everyone!

I am using RedHat 8.0 and using a 512kbps internet connection. I recently got the chance to test a 1.5Mbps connection out of my ISP's goodwill. I should be able to connect just by changing the username and password provided. I am using PAP, so I edited /etc/ppp/pap-secrets to include my new username and password.

Then I tried to reconnect by typing adsl-stop, then adsl-start. It does not appear to connect at all, so I called my ISP. On my ISP's side, there is no signal, no indication that I am even connecting to them. That means it is not the username and password issue. This is my output from /var/log/messages.

CODE
Aug  2 19:08:35 gateway adsl-connect: ADSL connection lost; attempting re-connection.
Aug  2 19:08:40 gateway pppd[16964]: Plugin /usr/lib/pppd/plugins/pppoe.so loaded.
Aug  2 19:08:40 gateway pppd[16964]: PPPoE Plugin Initialized
Aug  2 19:08:40 gateway pppd[16964]: pppd 2.4.0 started by root, uid 0
Aug  2 19:08:40 gateway pppd[16964]: Using interface ppp0
Aug  2 19:08:40 gateway pppd[16964]: Connect: ppp0 <--> /dev/pts/3
Aug  2 19:08:41 gateway pppoe[16965]: PPP session is 7318
Aug  2 19:08:41 gateway pppd[16964]: LCP terminated by peer
Aug  2 19:08:41 gateway pppoe[16965]: Session terminated -- received PADT from peer
Aug  2 19:08:41 gateway pppd[16964]: Modem hangup
Aug  2 19:08:41 gateway pppd[16964]: Connection terminated.
Aug  2 19:08:41 gateway pppd[16964]: Exit.


Is there any other file that I should configure other than /etc/ppp/pap-secrets? Will appreciate it if anyone can suggest where I should start troubleshooting.
feef
I wonder if it is ridiculous to say that Redhat 8.0 can only support up to 512Mbps? Or does it is not related at all? Has anyone used 1.5Mbps on a Linux box before? Will really appreciate any suggestions! sad.gif

Thanks!
hughesjr
Not a limitation I know of at all ...

is there a dsl setup config tool for redhat 8 ... it would be part of redhat-config-network.
feef
Okay, everyone, I got the 1.5Mbps problem ironed out.

It turns out that there is really no limitation for using 1.5Mbps as hughesjr said, and I couldn't connect using my test user id because I forgot to change the user in pppoe.conf. So basically the config files are all located in the /etc/ppp folder. I had to change the user ids and passwords in the following files : /etc/ppp/options, /etc/ppp/pap-secrets, or /etc/ppp/chap-secrets, and /etc/ppp/pppoe.conf

Just look through the files and change accordingly, but only the user id and password have to be changed, if you were to change from a 512Kbps to 1.5Mbps internet connection.

Thanks a lot, hughesjr! wink.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.