Help - Search - Members - Calendar
Full Version: Route...ifconfig...argh...
Linuxhelp > Support > Technical Support
johnwards
Hi Folks,

II have a comp with two network cards. Each with their own ip address.

We have a two networks that we want to connect together through this computer. (For interent monitoring file access etc etc)

Here is the output from ifconfig:

eth0 Link encap:Ethernet HWaddr 00:A0:CC:3A:16:53
inet addr:192.168.0.200 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::a0:cc3a:1653/10 Scope:Link
inet6 addr: fe80::2a0:ccff:fe3a:1653/10 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14409 errors:0 dropped:0 overruns:0 frame:0
TX packets:5844 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:1512567 (1.4 Mb) TX bytes:1644012 (1.5 Mb)
Interrupt:10 Base address:0xdc00

eth1 Link encap:Ethernet HWaddr 00:A0:CC:3A:1B:EF
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::a0:cc3a:1bef/10 Scope:Link
inet6 addr: fe80::2a0:ccff:fe3a:1bef/10 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:350 errors:0 dropped:0 overruns:0 frame:0
TX packets:61 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:47411 (46.2 Kb) TX bytes:5294 (5.1 Kb)
Interrupt:11 Base address:0xda00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

And here is the output from route:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth1
ip-192-168-0-0. * 255.255.255.0 U 0 0 0 eth0
default ip-192-168-0-2. 0.0.0.0 UG 0 0 0 eth0

I can ping the routing comp from each network but I cannot ping computers on the different network.

I am lost. I thought I had done every thing....

elp...

Cheers
John Wards
alex_123_sk
You have to enable ip forwarding for IPV4

echo 1 > /proc/sys/net/ipv4/ip_forward

You have IPv6 address bind to you NIC, I never use ipv6 so I cannot help for IPv6 stuff
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.