Help - Search - Members - Calendar
Full Version: Samba Share - Very Low Transfer Rate
Linuxhelp > Support > Technical Support
wannabe
Using Samba 3.0.3-5 on Fedora Core 2 with a public share on the FC2 box.
I can see the share fine on my WinXP sp1.
No errors in the logs or from the ifconfig command output.

But, it takes me just under 60 seconds to copy a 1,7mb file on to the share.

So far I tried this list below, with no diffrence I should add:
1. adding these lines to my smb.conf, one at a time with a service smb restart
;socket options = SO_SNDBUF=4096 SO_RCVBUF=4096
;socket options = IPTOS_LOWDELAY SO_RCVBUF=8192 SO_SNDBUF=8192
;socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
2. Disabled IPv6 setting the alias net-pf-10 off in /etc/modprobe.conf
3. Disabled DHCP config in my /etc/sysconfig/network-scripts/ifcfg-eth0
to get rid of the nameserver line in my /etc/resolv.conf from my DSL modem
and used my ISP nameserver instead.

My /etc/samba/smb.conf now looks like this:

[global]
workgroup = WORKGROUP
netbios name = o4_server
server string = o4 Samba
guest account = smbguest
security = share
hosts allow = 192.168.1. 127.
[Storage]
comment = Dump backups here
path = /tmp
guest ok = yes
guest only = yes
read only = no

The logs I'm looking at are:

/var/log/samba/nmbd.log
/var/log/samba/smbd.log
/var/log/messages

Can you pls point me where to go next?
Feeling like I've googled most of the linux forums already - sheesh! unsure.gif

edit: sorry, unable to edit the topic line, hence the "sama" blink.gif
Corey
I fixed your title for you.

What speed is your network supposed to be run at? 10Mbps or 100Mbps? I used to have problems with my server using samba shares when i had a 10Mbps, but as soon as I upgraded to 100Mbps, everything went a lot faster. I know that 60 seconds for a 1.7mb file is extreamly slow for a 10Mbps network, but still, the upgrade worked a lot better for me.
wannabe
Go figure, the cables here only do 10Mbps, all the NIC's can do 100Mbps but that's of no use to me at the moment. Guess my next step is to fix the cable ends/wall sockets and see what happens. Thx for the tip!
wannabe
For the record: Well, it works after I put this line in my smb.conf
CODE
socket options = TCP_NODELAY IPTOS_THROUGHPUT SO_SNDBUF 4096 SO_RCVBUF 4096

No idea why. Also, when I added it I started to get these errors(?) in the logs:
CODE
Aug  5 18:22:31 asdf smbd[2362]: [2004/08/05 18:22:31, 0] lib/util_sock.c:set_socket_options(159)
Aug  5 18:22:31 asdf smbd[2362]:   Unknown socket option 4096
Aug  5 18:22:31 asdf smbd[2362]: [2004/08/05 18:22:31, 0] lib/util_sock.c:set_socket_options(159)
Aug  5 18:22:31 asdf smbd[2362]:   Unknown socket option 4096

But I'm going to stick with it, at least until I get my cables fixed. Network util is steady at 55% on my XP pc, using 10baseT-FD settings from pc to switch and from there to the Samba box I'm using 100baseTx-FD. The final smb.conf looks like:
CODE
[global]
workgroup = WORKGROUP
netbios name = asdf
server string = Samba
guest account = smbguest
security = share
hosts allow = 192.168.1. 127.
local master = yes
preferred master = yes
socket options = TCP_NODELAY IPTOS_THROUGHPUT SO_SNDBUF 4096 SO_RCVBUF 4096
[Storage]
comment = Dump stuff here
path = /tmp
guest ok = yes
guest only = yes
read only = no

The local master = yes and preferred master = yes lines made no diffrence btw. Just keeping them to remember some of the stuff I came across.
It's very interesting to see that when I drop the 100baseTx-FD on the Samba box down to 10baseT-FD the network util promptly dops down to around 30%. So in conclusion, using these settings anyway, 10baseT-FD on a Samba server is a no-no.
hughesjr
Mine says:

CODE
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192


so try it with an = between SO_RCVBUF and the number .... and SO_SNDBUF and the number smile.gif

Like this (with your setttings):

CODE
socket options = TCP_NODELAY IPTOS_THROUGHPUT SO_SNDBUF=4096 SO_RCVBUF=4096


Most tuning articles for samba recomend 8192 instead of 4096 for SO_RCVBUF and SO_SNDBUF ... so I would go with:

CODE
socket options = TCP_NODELAY IPTOS_THROUGHPUT SO_SNDBUF=8192 SO_RCVBUF=8192
wannabe
The logs are clean now. Thx!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.