Help - Search - Members - Calendar
Full Version: Weirdest Problem Ever!
Linuxhelp > Support > Technical Support
eizo
OK, go figure!

I have Suse 9.0 installed. After instalation network interface worked. Next day when turned on my computer, I could not ping anything but my own IP. I checked hardware: OnLine LED on my broadcom (bcm4400 module) integrated controler was off. Network services started normaly (lo and eth0). I checked lsmod. bcm4400 is present and used (by them, I suppose).

Then I downloaded and compiled sources for bcm4400.o and replaced original bcm4400.o module. Still no LED indication.
After that I changed my IP in yast2. Some time after that I noticed LED was ON. I checked PINGing: it worked.
I rebooted. Haha, no LED, no network response again.

Ethernet controler failer, you would say! Naaaaa! I have windowsXP on same disk, and networking works fine. I also tried installing another PCI ethernet adapter, 3Com. Yast2 recognised it and configured it. But no network response from it in linux.

I noticed this problem after I updated BIOS on my A7V8X motherboard. I downloaded newest version. No progress.

This morning network worked, until I restarted machine into windowsXP. Since then I cannot bring my network to live. Kernel believes that hardware is OK, but as I wrote, no LED is on, as it should be.

Any idea?

Marjan
adam.stokes
Do you have firewall setup?
lesio1974
your cable might be failing

g
eizo
It cannot be firewall, becouse until recently exactly the same configuraton worked. Besides, hardware does not start correctly: no LEDS indicating traffic/connetcion.

Cable is fine: networking in windowsXP works well with it.

It must be either driver (but I dwownloaded and installed newest version) or somwhere mismatched linux configuration (how could that happend without my intervention?).
hughesjr
I don't know what version of the driver you have, but there are problems with that driver on SUSE 9.

http://www.musall.de/techdocs/linux/dell/i...i8600linux.html

Here is a fairly new source RPM for that drive specifically for SUSE 9. Don't know if it will help.
http://rpmseek.com/rpm-pl/bcm4400.html?hl=...m&cbn=0:B:160::

Are there no errors in either dmesg or /var/log/messages?
eizo
Fixed!
It was driver. This time I took it from Broadcom homepage, not ASUS. It worked immediatly.
THX anyway...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.