Help - Search - Members - Calendar
Full Version: Mandrake 10.0
Linuxhelp > Support > Technical Support
Hello, I am having problems with the resolution in mandrake 10.0 it stays at 640x480 and does not change. When I go into display properties that is the highest it will let me set it. Now I have asked for help before and was told I need to edit the lilo.conf file with a text editor, ok what text editor? What command opens the text editor? How do I open the lilo.conf file in the text editor. I have tried edit lilo.conf and I get the response command not found. The reason why I need it at a higher resolution is so I can click ok and apply after making changes to my system. You see I cant click apply if its burried under my screen and my resolution is not high enough to display the whole page. Now my system has started to shutdown randomly for no reason. I dont mean to sound stupid here but windows did not do this on this system. change computers because I have 30 of them mandrake same problems resolution jacked up and keeps rebooting. I liked 9.1 it worked great why did they change that. Is there place where I can download 9.1 because 10.0 in my opinion should not of been released. Oh I forgot to mention mandrake 10.0 does not make me use a password to login as a user or root and yes I set both during the install
Ok, so lets start picking this apart. First off let me introduce you to the wondeful world that is emacs. Emacs is, in my opinion, the best text editor, now so a flame war doesn't start up here, others will tell you that vi, or nano, or whatever, is better. So you can try what ever you want. They all open with the command of thier name.


Than if you want to edit a specific file you can have it already opened by typing

emacs /etc/lilo.conf

Or the like.

Ok, now that you know how to open a text editor, we should deal with your screen resolution problem. What kind of graphics card are you using? My gut says that your problem is in not having the right module loaded. However, you said it did work in 9.1? You didn't have to install anything when you installed 9.1 did you? Who told you to edito your lilo.conf file and what changes did they tell you to make?

Your lilo.conf file controles the boot loader and the only thing about your screen that would effect is your frame buffer durring boot up, it wont effect what happens after you boot up.

Write back and tell me what kind of video card your using and exactly what the problems is.

Mandrake 10 doesn't have a log in by defualt, ounce we get your screen fixed I will show you how to make it ask for your log in and password.
Ok, just joined an irc channel and they had me edit my X1186Config-4 file with vi. I did so I found that there are several monitors listed. Under each monitor there are resolutions listed. The monitor im using had no resolutions under it so I entered ModeLine "1024x768" then saved with "wq and exited the vi then restarted x. When I did nothing happened. And yes everything worked wonderfully in 9.1 why did I upgrade? Does anybody know where I can find 9.1 again?
well in order here are the distros ive tried and here is what went wrong

1. FREEBSD = x failed to load
2. Trustix = no gui (yes I need a gui)
3. lycoris = installs then when rebooting I get no operating system
4. peanut = im not going there
5. redhat = is not compatible with my intel 3com or trendnet nic card
6. Mandrake 10.0 = resolution and do not need passwords for logging in under users or root
7. slackware = freezes half way through the install and is not heard of again
Ok, so your making a common rookie mistake. Linux, unlike windows, doesn't always come cocked full of modules for everything. Lots of time you need to spend a little wile getting everything set up right and running befor your system is running slick. Ya, its a little bit of a pain, but in the end what you end up with is a system thats tailored to you and isn't bogged down my drivers and modules for things you don't have.

My advice to you is to go back to Mandrake 10 and instead of just bailing out on it because it isn't perfect out of the box, let us help you to make it work well for you. I had to wrestle with my first Red Hat system for over a week before I could get the dual head graphics to work right. But the guys here stuck it out with me and helped me get it running. Mandrake 10 is a really nice system and I would highly recomend you give it another try.

Alot of these things you gave up on are simple fixes. Mandrake 10 has a log password log in, you just have to check a box in the System Preferences. RedHat works with 3com stuff, you just need to load the right module. You think that RedHat could be come one of the favorites of IT nerds for networks if it didn't work with 3com products? Lycoris probably didn't install the bootloader right, thats an easy fix. FreeBSD probably just needed to install a module and configure your XF86Config file.

If you want to try linux, go back and re-install Mandrake 10, than post your XF86Config file and tell me what kind of video card your using and I will get you up an running.
just tried the fedora project well that did not last long. When loading kernel it crashes the computer thats not very stable. all these versions of linux reboot my computers yes I have several. I have tried loading it on 4 different machines it crashes them every time. Yes I have good power in my house and I ofcourse checked hardware compatiblity. is there a computer I can buy out there that supports linux? it sure does not seem like it. My windows 2000 never crashes been up for over 6 months no reboot, works like a dream when I ask it to change its resolution it listens. People say linux is more stable then windows im sorry I wish that were true I hate microsoft but there is a reason why it is #1 yes you can do more in linux then you can do in windows as long as linux says its ok. Windows will listen to me when I give it commands linux says command not found or says its changing the resolution but does not. Windows is clearly more stable then linux for it does not crash my computer before it even has a chance to load. Windows makes me use a password to login in under administrator linux does not care if I have a password still lets me login under root with out a password ( thats not safe). So linux is from my experience unstable not safe not secure in any way and incompatible with 98 percent of pc's out there. I dont expect to see linux taking over the market anytime soon maybe solaris but not linux.
I take that back I hate windows 2000 as well im not a linux basher just mad because I want to use it so bad but cant. this is my 4th day trying to get a distro up and running. ill try mandrake again brb
There is no linux disto (except live version of knoppix, and that doesn't count) that will let you log in as root with out a password as long as you set a root password.

I have to tell you that I have never heard of a windows machine that was able to run six months with out a reboot and still actually do anything. If you have a windows machine running that well than I guess stay with it, but I can't believe it.

Linux is more stable than windows, you just have to get it configured correctly. Thats the power of linux. The biggest difference between linux and windows and the thing you have to understand it, most linux distros don't try to configure themselfs for you unless you tell them to. That leaves all the settings up to you. That alows you to set it up the way you want it so it will run the best. Ya, its a little work, and ya you have to know what your doing, but its compleatly do-able.

You want proof of stability, somewhere I have the screen shots of my Mandrake system that had been up for 32 days, and the only reason I shut it down was because I had to move it home from school. I am sure other guys on this forum will vouch about systems they have had up for even longer than that.

I have only ever met one box that I couldn't get linux running on after a little set up work, and thats why I hate VIA, but thats another story. Linux is very compatable, its just not always compatable right out of the box like windows is. Windows is so fat and bloated because it has compatibility built in for everything you could possibly though at it. Linux is much more streamlined, and if that means that every now and than you have to install a module to get something running, so be it, I will take it any day to get out of Microsoft.

Sorry if this is getting long winded, but I really want to help you understand the glory that is linux. I understand your frustrated, most people are when they are new. But with time, you will learn and as you get more and more comfortable with linux you will enjoy it more and more.
when I type in emac I get command not found. I do not know how to copy and paste the contents of my X1186config file the only way I can open it is under vi editor. kwrite is the same command not found same with nano. Did mandrake come with a text editor? There are some things that should be installed reguardless of opinion your computer should come with a text editor. Oh great mandrake cant find its swap partition. Well I guess its time to reinstall mandrake again stable huh? stable systems dont forget about swap partitions
Ok, man, I got to come right out and say it, I think your screwing something up in the installation. I have never had it screw up this bad. Are you manually configuring your drive partition or are you letting Mandrake do it.

Its emacs with an s and nano probably doesn't come pree installed, vi and emacs are the two that are standard. Other ones can be added later.

Are you trying to create a dedicated system or a dual boot? And if Dual boot how are you settting it up?
im off to hunt down mandrake 9.1 or even 9.2 they worked so well. why did they release this joke called 10.0 that does not come with a text editor and yes I entered the root password during the install I know I did this trust me. I am a network specialist I configure cisco routers in large networks on a daily basis. Cisco routers run on a unix based os. How come I can get my network up and running I know how to make access control lists and setup dhcp all these things. Im not new to unix is what im saying im new to linux big difference unix like operating systems like solaris are stable and easy to configure and dont say no. I use solaris as well and like it very much its stable as hell. Linux is not stable even when you power off your windows box ive never had anything bad happen from an improper shut down even unplugging it does not cause anything bad to happen but when mandrake crashes my computer then restarts it cant find its swap partition. Yes ive used several different hard drives and tried several different video cards face it guys 10.0 should not of been released yet it just was not ready.
its a dedicated system
Sorry man, I have to say its you. I ran Mandrake for a long time both 9.2 and 10 and never had this many problems. You don't seem to be listening to me at all. Mandrake comes with text editors, both vi and emacs, unless your doing a package by package install and not selecting it, emacs and vi are included any of the default installations for Mandrake.

I could take 15 mins and have a running Mandrake system up on my box with apache, ftp, ssh, and mail servers running just by cheecking the boxes. It wouldn't take to long to put a dhcp server and a mysql server in either.

The problems you are having aren't normal at all which leads me to believe that you are trying to do stuff that you shouldn't and causing problems.

Your complaining about root privlages, how are you trying to gain them. su? or are you trying to log in? Or are you using sudo? I am telling you, Mandrake does not just alow users root access with out a password as long as one is set up. I have a hard time believe that you are having this much trouble with out there being an eliment of user error involved.
15 mins and I am now posting to you from my freshly installed Mandrake system.

I had to log in at the begining. I have to type in a password to run root commands. I have a running Apache server. Go to and you will get the fresh apache page.

All I did was a standard install. I selected standard security level. I had mandrake auto allocate the drive for me. I used the pre-selected packages with the addition of all the servers. And than I deselected the "Mandrake can auto log in one user" box after I set up my root password and user. And now I am going to do a unclean shut down and see what happens.
Everything is running fine. Sorry man, but I think your looking for reasons to not like Mandrake and I think your causing your own problems.

If you want to go back to the world of viruses and price gouging than thats your call. But if you would relax and slow down, you could use linux and get away from all that.
Speaking as a new Mandrake 10 user, I can say that perhaps you're being a little too aprehensive about Mandrake. Linux systems, by nature, are very configurable, and you have to make sure that someone (A boss, a neighborhood kid) hasn't messed with the system configuration.

0: Log in as Root (if possible)
If you can't... (or if you can)...

1: Click on the Star Button
2: Click System > Configuration > Configure your Desktop
3: Inside the System tab, click Login Manager

4: If you couldn't log in as root: Click the Users tab. Enable/Unhide Root. Go back, and login as root.

5: If you could log in as root: Click on the Convenience tab.
6: Disable Password-less Logins. Disable Auto-Login.
7: You may want to disallow uninvited sessions inside the Network-Desktop sharing tab too.

About your videocard, what kind is it? I was able to install all the Graphical Mesa Demos, on a Radeon 9200 and on NVidia Rage TNT 2-64 graphics cards, both with no problem, and I had 3d-accellerated screensavers going in under a minute.
I figured it out set root passwords and my display is where I want it everything as far as that goes works fine however now my browser just crawls it goes at 3.5kbs per second atleast thats what it says at the bottom of the page. I have a cable connection at 400kbs that does not make sense.
QUOTE (shetookhalf @ Jul 28 2004, 08:15 PM)
I figured it out set root passwords and my display is where I want it everything as far as that goes works fine however now my browser just crawls it goes at 3.5kbs per second atleast thats what it says at the bottom of the page. I have a cable connection at 400kbs that does not make sense.

Oh, are you on Comcast in Seattle? Yeah, I have that here in Burien, too, and I'm getting... (Brace yourself) 131.3 Kbps, over a Coaxial Connection. All of my outgoing servers have been firewalled by Comcast's routers. I'm switching to Speakeasy by the weekend. Comcast NO MORE!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.