Help - Search - Members - Calendar
Full Version: Vt 6103 Integrated Ethernet Problems
Linuxhelp > Support > Hardware Support
nate11000
I'm very new to linux and am having trouble getting my ethernet to work. I'm currently running KnoppMyth on my machine with a kernel of 2.4.25-chw. I have looked all over the internet looking for a driver for my integrated VT 6103 chip, and I can't find one... but I did finally find something that said that the VT 8235 rhinefelt.o would work. I downloaded it from viaarena, put it on cd and put that on the linux computer and finally figured out how to compile it. I then copied the rhinefelt.o file to the /lib/modules/2.4.25-chw/kernel/modules/net/ directory, following the instructions of the included textfile. I then went into the modules.conf which said that it was autogenerated and to look at the files in /etc/modutils so I went to that directory, modified a file called aliases to put in the line 'alias eth0 rhinefelt.o'

Still no ethernet... I have no idea what to do next. I'm at a complete loss and I can't find any other help on the internet. Thanks for looking at this post, and any information you can provide will be greatly appreciated!!!
hughesjr
What is the output of the command:

modprobe rhinefelt.o
nate11000
hey, thanks for responding! it's actually rhinefet.o not felt, i misspelled it the first time. anyway, i typed modprobe rhinefet.o and it said it could not locate the module. i also tried just rhinefet without the .o and it did not give a response, just a new prompt. does this mean it is not installed correctly? what i did to install the module is pretty much laid out in my first post. is there something else i need to do?

i double checked my spellings of rhinefet.o in everything on my comp that i moved or changed, and i never misspelled it on there.
hughesjr
do the command:

lsmod

and see if:

rhinefet

is loaded ...
nate11000
It's not. I then tried to do insmod rhinefet.o which gave me another command line with no message. then if i try again it says that a module called rhinefet is already loaded, but it still doesn't show up on the lsmod list. i think i'm giving up and buying another ethernet card. or just taking my computer to a field and pulling an Office Space on it.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.