Help - Search - Members - Calendar
Full Version: Samba Share And The Www Not Working Same Time
Linuxhelp > Support > Technical Support
I have played with linux a some on a duel boot with mandrake 8 and 9. but it as been a while.
To start, I am running Mandrake 10.1, on a AMD 800 with 512Mb ram, and about 100Gb worth of Hd space. This is a linux only system.
no sound, Cdrom, TNT 32mb video card, and one nic card.
I am planning to use this as a server for files and Game (unrealtourament) server.
Now about my network ... I have a 2wire Router/hub with NAT. and a Router/hub Wi-Fi with NAT disabled so the 2wire dose all the NAT for the network.
I have 5 systems(Built myself exp laptop). 3 Desktops running winxp Pro FAT32. 1 laptop with xp home ntfs. one desktop and laptop is using the Wi-Fi the other 2 system are connected to Cat5. The last system is my linux box. and it is also using cat5
(Sorry hope i donít seem long winded.)

I Install mandrake and i was about to connect to the internet just fine but once i setup samba (3) and get it to work i am no longer about to get to the internet. the 2wire is seeing the linux box and the widow system is seeing it.

Linux is setup to use DHCP so the 2wire is giving it it's ip address. It Seems that when i get samba working it trashes the internet and i can not work out why. I don't know what the difference is between ver 8 and ver 10.1 of mandrake that this doesnít want to work.

Thanks for any help you can give.

Ps yes it is ver 10.0
Do you mean Mandrake 10.0? I think Mandrake 10.1 is an Alpha release ... which I would NOT recommend for a normal user ... especially to run a server on.
it is ver 10.0 i read it wrong.
OK Got mad at mandrake so i formated and reloaded with Red Hat 9... I think i like it a lot better. but LOL i am still having the same problem. once i get the shares to work and it will see the other system the internet dose not work.
I have tryed to asign it a ip address rather than dhcp but that still is not working. i do have a active connection one for the network eth0:eth0 and eth0:eth1. but i am still unable to get to the internet at all. my shares are working no problem.
Is there some way i can connect the network up for IPX and the internet up for tcp/ip . Netbou is not avalible on windows xp i know that if i could set that up it would work.
Why are you using 2 eth0 connections?

With samba ... you just setup smb.conf. It shouldn't effect the rest of the network.

Something must be going on that I don't understand about your setup.
My network runs thought a Router/Modem that uses NAT and also has a firewall built in to it. (2Wire)
Internet .... Modem(2wire)..... Hub1 & hub2(Wi Fi) .... then all the computers are connected to the Hubs. the 2wire uses dhcp to give out local address to each computer. wi-fi or not. There is only one ip address for each computer and for some reson linux dosen't understand that it gets to the internet and the network from that Ip address. That is the Reson i was trying to setup ent0:0 and ent0:1 so that linux would rout internet thought one and the network thought the other. I AM AN DUMMY ON LINUX. I know i dont have something setup right but i dont know what it is.
Windows networks i know a lot about as well as windows systems. but i have only played with linux on a dual boot system and that was only playing around with it. and i was using windows ME on the rest of the system and NetBoue... I was about to get samba to use that to connect to the network so i didn't use Ip addresses for the network.... But now i am using Windows XP and that is the only thing it has.

So is there something i may be missing the the Samba setup? It setup as defalt right now. but i don't know what to change.

Thank YOu

If you get a good IP address via the router, and if your internet connection works after that, you should easily be able to add samba support.

(If DHCP is not working for eth0, the IP address of eth0 should be in the same network as all your other machines, the default gateway and the DNS server should be the IP address of your router ... and you can make the settings via redhat-config-network)

You want to ensure you have the following packages installed:


The command below should show those packages:

rpm -qa | grep samba

After your network is working, edit the file /etc/samba/smb.conf.

If you have a windows workgroup, change the following lines:

workgroup = your_workgroup_name

security = user

Create a user in linux that matches up with the user in windows (including passwords being the same).

You should then be able to connect to the windows shares.
Thank you That did Help but not fix.
heres what I did to fix it. (for all those reading this looking for fixes) "Remember that i am now using Red Hat this would probly work with mandrake as well. "

I had to Add a fake ethernet card in linux eth0:eth1 and i had to change it from DHCP to the ipaddress that it was using and setup the gateway address as well. So i have 2 ethernets listed in linux (i only have one NIC card installed in the system.) eth0:eth0 and eth0:eth1
eth0 is setup for DHCP and eth0 i put in the address that the DHCP is giving the System like and the 2wire has a gateway address of and i also used that address for the DNS as well.

so its working now with no problem.... Now if i could Just get Unreal Tournament to working i would be doing grate... But that my be another Post LOL.

Thank you hughesjr for Helping with this problem. That was the key that i need to make my fix work.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.