Help - Search - Members - Calendar
Full Version: A Whole New Can Of Worms...
Linuxhelp > Support > Technical Support
Chibix
Well, I did it. Mandrake 10 is installed and happily resides on the machine. It gets along great with the network, however, the local drive doesn't seem to mount when I want it to. {edit} I got the network drives to fileshare great.

How do I get Mandrake10 to automount /dev/hda1 if I get the problem listed below? "bad option, superblock, or too many mounted fs's"

(Other questions moved out of thread)
Jim
Wow thats a lot of questions, lets try to pick this apart one at a time. I am just going to start here.

Ok, first up, drives. I asume that your primary drive partition you want it to see if your windows drive? Well either way, you need to add a line to your /etc/fstab file. You will have to edit it as superuser but its pretty easy. You probably want a line that looks something like this...
/dev/hda1 /mnt/windows ntfs umask=000,users 0 0

That will automaticaly mount the first partition on your primary hard drive to /mnt/windows (make sure you create the directory. If you don't want it to auto mount add the option noauto. Than you can just mount it with the mount command.
Chibix
Okay, I have fstab open.

First thing I see:
# DO NOT EDIT: This is a generated file. To set mount points,
# file system types, or mount options edit /etc/harddrive.inf.

Unfortunately, etc/harddrive.inf doesn't exist yet, hidden or not.

I already have a line resembling:

/dev/hda1 /mnt/windows vfat umask=0,iocharset=iso8859-1,codepage=850,showexec=no,noexec 0 0

And I'd like it to AutoMount. Do I put that in fstab, or create a harddrive.inf?

In other news, I've managed to convince Epiphany and Mozilla that I really desire boogle.com as a start page. Konqueror, however, starts with "file:/usr/share/doc/HTML/index.html". It seems there is only a setting to change the 'home' button and not the default 'start page'. Every cell in my body wants me to believe that those two things should be absolutely the same.
dry.gif
hughesjr
jeez ... don't read the top of the files !!!! laugh.gif

it should already automount

Is there a directory called /mnt/windows ? .... if so ... does it contain your files?

...if not ... create the directory /mnt/windows with the command:

mkdir /mnt/windows

When you reboot, /mnt/windows should contain your files.

(Is your Windows installed on a fat32 partition ... that is what it currently is set to).
Chibix
That's just the problem. There is a /mnt/windows, and it doesn't contain my files.
hda1 is indeed a fat32 partition. Ooh, looks like it never did mount.

$ mount

/dev/ide/host0/bus0/target0/lun0/part5 on / type reiserfs (rw,notail)
none on /proc type proc (rw)
none on /proc/bus/usb type usbdevfs (rw)
none on /dev type devfs (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw,mode=0620)
none on /mnt/floppy type supermount (rw,sync,dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,codepage=850)
//cti-1/C on /mnt/C type smbfs (0)
//cti-1/D on /mnt/D type smbfs (0)

$su
# mount -a

mount: wrong fs type, bad option, bad superblock on /dev/hda1,
or too many mounted file systems

# mount -t vfat /dev/hda1 /mnt/windows
# ls /mnt/windows

autoexec.bat* Program Files/ dos/ BeOS/ beos.bat* ifshlp.sys* io.sys* command.com* msdos.sys* win386.swp* config.sys* windows/

# SUCCESS!


{edit} This gives rise to another problem.

$ cd /mnt/windows
bash: cd: /mnt/windows: Permission denied
$


So how do I make it always do that, but give access to people other than SU?
Jim
Thats what the modifier users does in the fstab mount, it alows everyone to edit it. Go back and tweek the fstab file to do it for you, than you will be able to access it from any user.
Chibix
After trying a few different options found around the net, I went with
/dev/hda1 /mnt/windows vfat rw,auto,umask=000,quiet 0 0
and it worked! Woohoo!

Thanks for the umask fix, Jim!
Jim
Your welcome, where there still problems you need help with out of this post? You said something about network drives?
Chibix
Network drives, nope, everything basically works there. With one exception. I can't seem to copy any sort of files to hard drives across Samba to or from a windows machine. Am I supposed to be able to do that?

{edit}
I can copy files from the linux box using the windows machine, and I can copy files from the windows machine using the linux box, but not vice versa. So it's only one-way, downloading to each, from the other. No write permissions.
{/edit}

It only upsets me because I can't do it and because that windows (ME) machine (800 Mhz) is my firewall/internet server at the moment. (See; the creepy eye)
Jim
Linux does't have a stable NTFS write yet. They have experimental, but I wouldn't use it on any system you want to keep up and running. If you use it, its a question of when, not if, it will screw up your NTFS drive and your files. Thats probably what your problem is.
Chibix
All my partitions are vfat.

Linux will read/download from the vfat drives across the network. But it will not upload/write to. How do I set that.

Windows will now read/download from the linux Reiser drive from across the network, but will not write/upload. How do I set that too?
hughesjr
from across the network ...

How are you conencting to the other computer?

I normally recommend using samba to do these sort of connections.
Chibix
Samba.

I installed LinNeighborhood, and it seems to have no problem letting me delete things in MidnightCommander.

Now if only I could get these drives to Mount! /mnt/ takes a long time to ls, even in Konqueror.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.