Help - Search - Members - Calendar
Full Version: Doom Legacy Libxxf86vm.so.1 Needed
Linuxhelp > Support > Technical Support
Robert83
Hi,

can anyone tell me what do I need to install on my Whitebox in order to get this working (Doom Legacy)

this is the error I'm getting :

[robert@Robert doomlegacy]$ ./llxdoom
./llxdoom: error while loading shared libraries: libXxf86vm.so.1: cannot open shared object file: No such file or directory


Sincerely
Robert B
hughesjr
see if you have the static version of the package libXxf86vm.a, do:

ls -al /usr/X11R6/lib/libXxf86vm*

If you have this:
-rw-r--r-- 1 root root 15978 May 14 15:08 /usr/X11R6/lib/libXxf86vm.a

Then do:

cd /usr/X11R6/lib/
ld --whole-archive -share -o libXxf86vm.so.1 libXxf86vm.a


Make sure that the directory /usr/X11R6/lib is in the file /etc/ld.so.conf then issue the command:

ldconfig

Then you should have a working copy of libXxf86vm.so.1 ... reissue the command:

ls -al /usr/X11R6/lib/libXxf86vm*

You should see:
-rw-r--r-- 1 root root 15978 May 14 15:08 /usr/X11R6/lib/libXxf86vm.a
-rwxr-xr-x 1 root root 16479 Jul 19 17:28 /usr/X11R6/lib/libXxf86vm.so.1
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.