Help - Search - Members - Calendar
Full Version: Grub Problem
Linuxhelp > Support > Technical Support
ahilliar
I have recently installed suse9.1 on a dual boot system with windows xp. suse runs fine and I like it alot, but when I tried to run windows I discovered a problem.

In grub, after choosing Windows from the list of boot options, I get the following error:

QUOTE
root (hd0,0)
  Filesystem type unknown, partition type 0x7
chainloader +1


My hard drive is physically partitioned in this order:
windows C > windows D > windows E > windows F > suse
with all win partitions as NTFS

I can access all my windows files from suse, it even automounts all the windows partitions in /windows which I think is pretty cool, but I do need to actually get into windows

Please help
ahilliar
Here is my grub.conf file:

[quote] root (hd0,8)
install --stage2 = /boot/grub/stage2 /boot/grub/stage1 d (hd0) /boot/grub/stage2 0x8000 (hdo,8) /boot/grub/menu.lst
quit[/quote]

Here is the windows section of menu.lst:

[quote] title Windows
root (hd0,0)
chainloader +1[/quote]

I tried editing it to:

[quote] title Windows
rootnoverify (hd0,0)
chainloader +1[/quote]
but that just changed my error message to:
[quote]
rootnoverify
chainloader +1[/quote]
My partitions in greater detail:

/dev/hda1 = windows C
/dev/hda2 = extended
/dev/hda5 = windows D
/dev/hda6 = windows E
/dev/hda7 = windows F
/dev/hda8 = linux swap
/dev/hda9 = linux root

Could my problem have anything to do with the fact that what linux calls my windows C drive is actually labeled in windows as H (dont even ask)?
ahilliar
Ok I fixed it, this worked on the first try for me:

http://portal.suse.com/sdb/en/2004/05/fhas..._booting91.html
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.