Help - Search - Members - Calendar
Full Version: "kde Is Unable To Start"
Linuxhelp > Support > Technical Support
Onestep
Tonight when I booted up Mandrake 10.0 Official & tried to log into KDE 3.2 I received the following error message:

"The following installation problem was detected while trying to start KDE:
No Write Access to '/home/kurt/.ICEauthority
KDE is unable to start"


so I clicked "O.K." and another message box poped up:

"cound not start ksmserver. check your installation"

I clicked "OK" which brought me back to where I choose what WM I want to use. I selected Fluxbox this time. I was able to fire up Fluxbox O.K. , but when I started up Konqueror I received the following error message:

"DCOP communications error (Konqueror)
There was an error setting up inter-process comminications for KDE. The message returned by the system was: Could not read network connection list
/home/kurt/.DCOPserver_my_isp_address_&_provider.
Please check that the "dcopserver" program is running!


so I clicked O.K., Konqueror fired up, I got the same error message again, clicked O.K. and was able to then use Konqueror without issue.

Whats up with my system?????
(and tonight I thought I'd tackle my "no sound" problem... wrong!)
hughesjr
Are you maybe logged in as one user from the console ... and then used su to switch to another user prior to starting X?

Linux doesn't like that ... and it gives similar results.
Onestep
Problem solved... here's what I did:

QUOTE
No Write Access to '/home/kurt/.ICEauthority
KDE is unable to start"


I got thinking about this so I found the file .ICEauthority and looked at it's "permissions". It had "rw- --- ---". I changed it to "rw- rw- rw-", rebooted, and the problem went away!

I'm not sure if what I did has any unknown consequences or not.

All I do know is that I can run the KDE desktop again, and when I fire up
Konqueror I no longer get the error message:

""DCOP communications error (Konqueror)
There was an error setting up inter-process comminications for KDE."

Now to figure out my 'sound' problem...
hughesjr
It should have been able to run the other way ... are you logged in as the kurt user while you are doing this?

Did you change the kurt user's group permissions?
-----------------------
Onestep
In order to change permissions I fired up a terminal (consol?) as root "su".

When I first booted up and had the problem, I selected user "kurt" to log into KDE with.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.