Help - Search - Members - Calendar
Full Version: Problem With Red Hat Installation
Linuxhelp > Support > Technical Support
yelpingsalmon
I just recently installed Red Hat. After the install it rebooted and did all its installation business, but then when it tried to boot for the first time my monitor goes black. And it stays black...i dont even get to the log in screen. Someone please tell me what i should do...
Jim
I am guessing that your having a problem because your video card isn't configured yet. Start by switching over to a command line boot, than tell us what kind of video card you have and we can go from there.

To switch over to a command line boot follow these steps:

Fire up your machine and when grub loads up highlight the Red Hat boot option

Press e to edit the line

Arrow down to the kernel line and pretty e again.

Add the word single and pretty [enter]

Now press b to boot the edited line.

Ounce the system boots up you will be in whats called sinlge user mode. Change directories to /etc and fire up an editor of your choice, emacs is good, and open the inittab file
emacs /etc/inittab

change the line
id:5:initdefault:[b/]
to
[b]id:3:initdefault:


and reboot, that should get you a command prompt. If it doesn't, we will need to try something else.
yelpingsalmon
Ok I tried that, but it still does the same thing...after going through the install checklist er w/e monitor turns black and makes sparkly noise. I noticed something though, when it was going through the list.
It said everything was [OK] in green lettering except for this thing..."Bringing up interface eth(theta symbol).....[FAILED] then beneath that it says something about "is link cable connected?"

So im guessing I put the wrong monitor in when i installed...O_o

I'm sure i had to right video card cuz i looked it up, but I wasn't sure about the monitor.
Jim
eth stands for ethernet, so that just means your system isn't on-line. Durring the boot up does it say "Entering Run Level 5" or 3?
yelpingsalmon
It says 5.
hughesjr
Do you have a NFORCE 2 motherboard and an Nvidia video card?

You have to boot to console mode ... ie run level 3, to fix the problem.

when booting, at the grub prompt, press e.

go to the kernel line and press e again ....

add a space and 3 at the end of the kernel line.

You should then boot into run level 3.

Then run redhat-config-xfree86
yelpingsalmon
It allowed me to boot in level 3. I tried to run that program, but once again black screen of death.

128mb DDR NVIDIA GeForce FX 5200
idk what my motherboard is...
hughesjr
you will need to edit your /etc/X11/XF86Config file by hand .... using a console editor.

vim or emacs or pico could be available.

You will need to know how to operate these editors ... pico is probably the easiest if you don't know how to use one of the other ones.

You need to search for and find the line:

Driver "nvidia"

(or Driver "some_text" if it is not set to "nvidia")

change the text inside the quote to "vesa" ... so now it should be:

Driver "vesa"
----------------
Next, set the monitor to a generic monitor ... find the lines:

HorizSync
VertRefresh

Set them to this:

HorizSync 30-35
VertRefresh 50-70


This save the file ... this should allow you to at least boot into a mode so you can set your video card up.

I would recommend that you use FedoraCore 2 instead of RedHat ... the hardware detection is much better....
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.