Help - Search - Members - Calendar
Full Version: Apache 1.3 And Mod_php On Suse 9.1
Linuxhelp > Support > Technical Support
Well...... here goes.

SUSE Linux 9.1 only ships with Apache 2. Unfortunately I need to use Apache 1.3 and mod_php so that I can run ezpublish 3 on my box. Ezpublish 3 is not supported on Apache 2, I've tried it and it will not run.

I found and installed the Apache 1.3 RPM's for SUSE 9.1. Apache 1.3 ran OK, but trying to get mod_php to install and run is a nightmare.

Apache 1.3 obviously does not use the mod_php installation for Apache 2, but there is not an installation that I can find for SUSE 9.1. There are some RPM's for earlier SUSE releases, but these throw up a whole screed of inconsistancies and multi-theading stuff that needs to be installed (no sign of that anywhere for download).

YAST also seems to insist on uninstalling Apache 1.3 whenever I use it, and after several days of trying to solve this whole issue, I am thoroughly frustrated (I have tried and tried again in various ways and searched all over the web before bringing this problem here).

So..... has anyone got Apache 1.3 working with PHP (and MySQL though that's not been a problem so far) on SUSE 9.1.

Andrew :-/

p.s. It seems to me a bit barmy that SUSE only seem to support Apache 2 for SUSE 9.1 when there are still so many "issues" with it and PHP4 etc. As far as I am aware it is still not widely reccomended for live servers (especially enterprise stuff).
Most newer distros support Apache2 .. and most people I know are using it with PHP4.3.x ... without major problems. There was a problem with PHP threading and Apache2, but now all the distros turn off that feature in their apache2 compiles.

Ezpublish says it works with apache 2:

So, if you install all the MySQL, Apache, PHP and mod_php stuff ... and ImageMagick and/or gd then it should work...
If you still want to use Apache and not Apache2, I would recommend building the Apache from sources:
Here are a couple good examples of this:

Here is a walkthru that I did on Debian Sarge and LAMP (my example is Apache2):
Thanks, I'll have a look at all that (I was hoping that compiling wouldn't be the only solution, but heigh ho).

That page on the ezpublish site is a bit misleading though since they don't do support or bug fixes for Apache2.

To elaborate a little more on the PHP4.3.x and Apache2 threading problem:

I use php4 and apache2 in production on RHEL and clones of RHEL (WhiteBoxEL, CentOS, TaoLinux). The PHP compiled on those distro's uses the prefork MPM. I know plenty of people who use PHP and Apache2 in production...

SUSE 9.1 supports this via the RPM in Yast (your version may vary, based on updates):
Yep, that's the setup I have with the prefork MPM etc.

It doesn't seem to be a problem with my LAMP installation (with Apapche2) as such. Several other programmes run on it (eg. phpadsnew and phpMyAdmin). EzPublish, as you and they say, has pretty low requirements for running in the LAMP environment, it's just that it doesn't seem to like my Apache2.

I did have SUSE 8.2 with Apache 1.3 etc. on it that did run EzPublish. I'ts a bit of a sod really since I don't want to go back to the 8.2 version since 9.1 recognises all my hardware (including stuff that quite surprised me) which 8.2 didn't.

It's a pity that SUSE don't offer the choice of Apache 1.3 "out of the box" so to speak. All that dependecy/broken libs seemingly by the dozen is a bit mind boggling.
I am expecting a SUSE 9.1 cd in the mail in a couple days ...

If you want, I will build an LAMP server with the latest apache 1.3.x, php4.3.x, and mysql 3.x from sources and see how it goes.
What exactly about ezpublish isn't working on your apache2 prefork setup?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.