Help - Search - Members - Calendar
Full Version: Change Desktop Gui
Linuxhelp > Support > Technical Support
ctrunk514
With Mandrake 10, from the command prompt, how do I change my GUI from KDE to GNOME? and then back again (both are installed).
ctrunk514
switchdesk does not seem to be installed with mandrake
VBD
Hopefully this works on mandrake. It works on most distro's i've used. Do the following:
# su
# cd /etc/X11/xinit
# ls
You should now see a list of files that look like the following:
#init
#xinitrc.kde
#xinitrc.fvwm
#xinitrc.gnome
There could be a few others. Now, choose the Window manager (GUI) you want to use. If you wat gnome, do the following:
#cp xinitrc.gnome xinitrc
This copies gnome's xinitrc to the xinitrc that is read when xserver starts. Hopefully this works under mandrake. If you have a graphical login (KDM, XDM), which I remember mandrake booting into, just use that. Choose a user. Then there is a menu somewhere where you can choose the window manager you want to use. Then just log in. If you wish to do it from the command line though, the above should work.

(I edited it to fix Su. It should be "su", not "Su")
Jim
Just log out, there is a session chooser built into the log-in screen. All you have to do is change the session type in the drop down menu.
ctrunk514
VBD -- I do not see thouse file you were talking about xinitrc.kde, .gnome or anything else. Also if I do a locate xinitrc.gnome nothing comes back

lest0039 -- im not sure I follow. boot up and im at the command prompt, I log in as a user or root (dosent matter) and type startx. KDE comes up, there are no options; straight into KDE. What am I missing?

Thanks again for the help
Chris
wookmaster
when you start your computer it takes you to the command prompt? I have MD10 and it brings me to the GUI log in. Did you configure it not to? When I mess with my video and it kicks me back to console login I cant get the GUI login to come back unless I restart
Jim
Do this, open your /etc/inittab file

there is a line that looks like this

id:3:initdefault:

Change the three to a 5 that will make you come to the graphical log in when you start up your computer.

That you will have the option to choose your session type. That will alow you to switch around. Than when you log out of KDE instead of being taken to the command line, you will be taken to the log in manager.
ctrunk514
Sounds good, but I prefer to start at the command line.

I figured out that I can start gnome by search for gnomerc and running it from the command line, just wondering how to make gnome the default.

Thanks for all the help
Jim
Mandrake uses what ever your last session was for the default. So if you go through and change it using the init 5 junk it will stay after you change it back to init 3. You can also edit the default x session in the /etc/rc.conf file.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.