Help - Search - Members - Calendar
Full Version: Make Bzimage
Linuxhelp > Support > Technical Support
cyris
running redhat 6.2 with 2.2.14-5.0. im trying to compile 2.4.26 doing the following steps

cd /usr/src/linux-2.4.26
make mrproper
make menuconfig
make dep
make clean
make bzImage

make bzImage spits out the following error.
make: *** No rule to make target `bzImage'. Stop.

I also tried the following
make vmlinuz
make: *** No rule to make target `vmlinuz'. Stop.

does 6.2 just not have bz2 ?
what can i do?
Hemant
I think you missed the step of making modules...
cyris
thats after make bzImage
Hemant
Yeah..true..make modules is after that..Sorry for that..
But kernel compilation had nothing to do with what version of Redhat u are using.

So you have downloaded kernel-2.4 from somewhere..and now you want to install it...Just to make sure that you have not missed something i will repeat the steps..
1.Copy the existing kernel source to somewhere else.
*cd /usr/src
2. rm linux
3.tar -jxf linux-2.4.26.tar.bz2
4.mv linux linux-2.4.26
5.ln -s linux-2.4.26 linux
6. cd linux
7. make xconfig
8. make dep
9. make clean
10. make bzImage
*copy the existing modules somewhere else.
11. make modules
12. make modules_install
13. make install (you may wish not to use this step).
Just follow these steps..and let us see if some error comes up.

but one more thing...your problem looks like as if the makefile is not proper..either your makefile is corrupt or somebody has edited it by hand.Because makefiles are of the format..
CODE
OBJECT=xxx
FLAGS=
......
......
clean:
      rm -rf *.o *~
install:
      cp xyz 123
bzImage:
      cc -DHAVE_CONFIG XYZ

so in your make file..this rule called bzImage is missing.You may try make zImage.

PS:my steps are different than yours.
hughesjr
I agree with gethemant, it should not have anything to do with what version of redhat you are using.

make bzImage

should work...where did you get the kernel source from?
------------------
BTW ... that is a Captial i .... not a lowercase L in bzImage ... (you posted it correctly, so you probably did it right, but they look the same in some fonts).
------------------
gethemant ... I'm not sure what your step 4 does

4.mv linux linux-2.4.26

When I unpack the kernel, it is already named linux-2.4.26 ... and linux is normally a link (which you deleted in step 2, and properly recreate in step 5) ... If I don't do your step 4, your directions work perfectly for me ... am I missing something?
cyris
yup i did all the above steps correctly and I agree with you guys that it shouldnt matter what version im running.
I did the following...

CODE
cat Makefile | grep bzImage

CODE
cat Makefile | grep zImage


both are not even in the makefile, so i think thats a problem.

when i go to save my config file from menuconfig, does it matter what name i give the file?
hughesjr
you should name it .config
cyris
thats what I named my config file. i dont get it. it seems that im doing everything right.
cyris
got my kernel src from kernel.org

im running the sparc release if that helps.
hughesjr
I have never tried to build a kernel on a sparc machine.

From a help file:
QUOTE
And that's it! Save your configuration and compile with a make vmlinux. There is no make zImage for Sparc. My kernel compiled just fine. I went ahead and adjusted my silo.conf file to point to the new kernel and rebooted.


So ... it looks like sparc does not support compressed kernels....

Learn something new everyday laugh.gif
Hemant
Amazing..... biggrin.gif biggrin.gif biggrin.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.