Help - Search - Members - Calendar
Full Version: Su Segmentation Fault
Linuxhelp > Support > Technical Support
nifflerX
Hi,

I recently did a clean install of RHEL WS version 3 and updated them via up2date. My problem is I can't use the command 'su' anymore as I could in RedHat 8.0. When ever I type in 'su <username>' I get asked for a password, then I type in the password for the username and it tells me a segmentation fault occured. I've even tried to use 'su <username>' while logged in as root, and when I do that I get the following error:

su <username>
free(): invalid pointer 0xb759d470!
Segmentation fault

I'm not having problems becoming root or anything like that, to do that I use the command sudo -s, what i need to be able to do is have one user logged in, and then log in on top of them in a terminal. If anyone has any thoughts or suggestions I would really appreciate them. Thanks so much.


-NifflerX
hughesjr
Sounds like a progam error ... what happens if you use the command:

su - username

....

one thing to check for is a full partition where temp files might be written. (/tmp ... /home)
nifflerX
If I do

su - username

I get the same error: Segmentation fault

What should I be looking for in the /tmp or /home directories? I see a lot of directories entitled orbit-username in /tmp, as well as a few ssh-<series of letters>. The only major setup change I've done is to remove the file /tmp/.X0-lock because when a user logs out, having it there causes and error message to show up. But this shouldn't affect su, should it? Thanks so much.


-NifflerX

EDIT: Sorry I didn't quite understand your post before. My /home partition is only 4% used and my / partition, where /tmp is help is only 27% full. Any other thoughts or suggestions? Thanks so much for helping me.
hughesjr
Have you done anything wierd (compiled your own kernel or glibc, etc.)?

The package coreutils provides the file /bin/su ... the latest version is 4.5.3-26 (which I think us the original version).

I would try to reinstall that rpm with the command:

rpm -Uvh --force coreutils-4.5.3-26.i386.rpm
nifflerX
Sorry it took so long for me to reply.

No, I haven't done anything odd with the installation, the only odd thing I have is the most of my users are network users so I don't have too many local accounts on my machines. I did an rpm search and found that:
CODE
rpm -qa | grep coreutils
coreutils-4.5.3-26

So I downloaded coreutils-4.5.3-26.i386.rpm from http://caos2.caosity.org/build8/testing/i3...6/RPMS/?C=N;O=D but after running the rpm -Uvh --force command I still couldn't use su. The installation went fine and produced no errors, but trying to su to another user still caused a segmentation fault. The coreutils I'm installing are from a Red Hat CD (not even one I bought). Is there anything else I might be able to try? Thanks so much for all your help.

-NifflerX
chrisw
are you authenticating against an ldap server because if you are, i have read i believe on bugzilla for redhat that there were issues with "su" using it against a ldap server for authentication purposes..i dont exactly know the fix but that might be the issue you are having...thats if you are using ldap
nifflerX
I am using ldap. Thanks very much. I'll search for any information on fixes or other's experiences with that. If anyone has had any experience authenticating with an ldap server I'd love to hear how it went. (especially if it went well smile.gif. Thanks so much.


-NifflerX
hughesjr
Chris - you are the man!

Here are some references:

http://bugzilla.redhat.com/bugzilla/show_b...g.cgi?id=116282

http://bugzilla.redhat.com/bugzilla/show_b...g.cgi?id=114575

Not really sure what will make it work...
chrisw
the only thing i remember is something with the
/etc/pam.d/su file had to be edited in some way....

im not positive but research the links that hughes
posted and it might be in there....


naw, im just glad i could provide an answer and
lead someone in the right direction....
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.