Help - Search - Members - Calendar
Full Version: 23" Apple Cinema Display --red Hat Ws--please Help
Linuxhelp > Support > Technical Support
After countless hours on the phone with Red Hat, ATI, and Apple, as a newbie to Linux, I am beginning to think there is no place for me and my 23" Apple Cinema Display, which as I regret, worked beautifully as a dual head on Windows. So I am turning to the community that created this incredible OS for help on how to get Red Hat Pro WS running XFree86 4.3. Is there is way to get this monitor to work on my ATI Radeon 9800 Pro card under Red Hat? Any help is soooo greatly appreciated as I am drawing closer to the thought of having to go back to windows. sad.gif

Thank you in advance,

I understand you may have to ask some questions but stay reashured that will check this thread religiously to help in any way.
I will tell you what, you put it in a box and send it to me, I will send you a 15 inch DFP which I know works with Linux and everything will be fine any happy. How does that sound? No, ok, worth a shot.

A couple things, what exactly is the problem? Are you not getting a signal, are you getting a signal but it isn't decoding right? Whats do you see on the screen?

Are you using it as the second out? I asume the card has a VGA and a DVI out and you are plugging a standard monitor into the VGA and the God of an Apple display into the DVI with the Apple converter. If that is the case have you set up Xinerama for dual screen display? Have you installed a module for the Radeon card?

These are things we need to move on, get them up and we will trudge forward, in the name of all that is holy I want to see this work.
ok...well let me explain one fundamental issue with this will not display anything on the screen as soon as the computer starts up. For example, I would never be able to view BIOS configuration on this screen becasue the screen won't display anything until after the drivers are loaded i presume. So here is what I have done so far.

When I installed Red Hat I needed to see the boot menu and install wixard and things so I disconnected the screen and used a 15in Sony SDM-N50 which worked fine. So once i got everything installed I completed all the updates that were available by the Red Hat updater. After the updates were installed I noticed that convieniently under the Generic LCD Display in Monitor Settings there was "LCD Panel 1920x1200" which is the native resolution of the display. When you select this you get a hsync of 31.5-90 and a vsync of 60.
So now that I seemingly had the right screen selected I needed to make sure that the driver was right. When I first atempted to load X it failed becasue of the default driver that red hat put with my card. Red Hat tech support told me to use the following command [redhat-config-xfree86 --set-driver=vesa] which obviously set the driver to use vesa. This worked and got me into X but they told me to change it once i got in. So...I went to ATI's website and downloaded the ATI radeon 9800 pro driver for linux. It was not very easy to install nor use but I did anyway. So...finally with that driver and the seemingly correct screen installed i shut down the machine and switched to the apple cinema display. Just as I hoped the screen eventally came up at the Red Hat logon screen but interestingly it was displaying only 1600 pixels of 1920 from the width. So basicly on the right hand side of the screen...there was a gap filled with verticle muticolored static lines. So if anyone has any ideas you have no idea how greatful I would be. I will also make sure to distribute this fix as many people seem to be atempting the same thing.

Thank you in advance,
Check in the file named /etc/X11/XF86Config

Look for the section named Section "Screen" (here is mine):

Section "Screen"
       Identifier "Screen0"
       Device     "Videocard0"
       Monitor    "Monitor0"
       DefaultDepth     24
       SubSection "Display"
               Depth     24
               Modes    "1024x768" "800x600" "640x480"

Make sure the mode that you want is listed there ... (ie 1920x1200)

Also, what is the driver listed in the Section "Device" section for your video card (mine says):

Driver "ati"

yours should be (i think)

Driver "fglrx"

I had the same Radeon 9800 card and the 23" Cinema Display running Suse 9.0. The behavior you've described (blank screen during boot up, etc) is the exact same problem that I had. I've read various other posts here and there and this appears to be normal with Radeon 9800 and the display. I lived with it quite awhile, but the difficulty was compounded because I use a dual-boot system and I couldn't see the boot menu, and heaven forbid there was an error condition that needed intervention before the display kicked in.

On the other hand, once the display was up, it was beautiful. The native 1920 x 1200 resolution worked perfectly but I was never able to enable 3D support despite many valiant attempts.

Here's a link that helped me to set the resolution and the horizontal and vertical sync values. I'm hardly a Linux wiz but I was able to edit the XF86Config file with little trouble

On a sad note, I was never able to completely cope with the blank boot screen and after much consideration I sold my Radeon 9800 Pro and went back to my old, but trusty GeForce ti4600. I can tell a small difference in 2D display quality, but had no trouble enabling 3D support and I can at last see my boot screen again. Not much help in your case, I know, but at least you know someone has been where you are :-)

Wonderful guys thank you. I will give all of this a try. I may even go to a Nvidia card becasue I need 3D support to work.

Thank you,
to try and fix the console problem, use a space and this vga statement at the end of your kernel line in /boot/grub/grub.conf.

which is 1280x1024 32bpp


which is 1024x768 32bpp
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.