Help - Search - Members - Calendar
Full Version: Installing Oracle 9i Into Rh 9.0
Linuxhelp > Support > Technical Support
Hi, wonder if anyone could help me with this.... tried for 1 whole day but unsuccessful. sad.gif

Just installed red hat 9.0 into a clean P3 700 512Mb.
Tried to install Oracle 9i application server into linux but keep having this error.Installed j2sdk1.4.2 into usr/local folder.
"[cslucas@localhost cdrom]$ Initializing Java Virtual Machine from /tmp/OraInstall0/jre/bin/jre. Please wait...
/tmp/OraInstall0/jre/bin/../lib/i686/green_threads/ symbol errno, version GLIBC_2.0 not defined in file with link time reference ( to initialize threads: cannot find class java/lang/Thread
Could not create Java VM "

I have installed Oracle 9iR2 database several times on Linux ... I have not installed Oracle 9i Application Server.

I found this site invaluable when doing the install. (I know this isn't for 9iAS ... but it still might be helpful).

I would also recommend that you do not use RH9 (oracle products are not certified for RH9) for the install ... but instead use CentOS-3.1 or WhiteBox Enterprise Linux (they are both RedHat EL 3 AS clones).
Why in the world do you need oracle9i Applications Server....

Where i use to work , they installed it and i was around to help
and i didnt like it what so ever...its hard..its difficult and it
horribley frightening to do...

i really dont want to scare you away from installing it...
and yes the install is definitely different then just the oracle9i database install

the reason is that the application server is not certified to run on redhat9

like hughesjr mentioned i would try and install centos2 instead because
its more closer to certified then centos3 or whitebox is...unless its
certified on rhel3 already...not sure

trust takes more than a day to get it installed...
have lots of coffee, sugar filled products and lots of things to do
while it installs..

thats all i have to say....

I just checked at metalink and the Oracle 9i Application Server (9.0.1 - 9.0.3) is not certified on RHEL 3 ... only RHEL 2.1

Oracle 10g Application server (9.0.4) is certified for RHEL 2.1 and RHEL 3.0 ....

So, centos 2 might be a better fit if installing 9.0.1 - 9.0.3 application server.
cslucas - if you have access to metalink, see these pages:

then select your version of application server and you can get all the release notes for the product and see which linux versions it installs on.

BTW, Why are you trying to use j2sdk1.4.2 ... Oracle comes with it's own version of jdk .... here is a quote from metalink:
In general, Oracle9i Application Server Release 2 (9.0.2) and higher supports using JDK extensions higher than one the product originally shipped with. For example, on 9.0.2 and 9.0.3, it is possible to move from 1.3.1_06 to 1.3.1_07 or beyond. However, if you want to use different JDK versions (example: 1.3.x to 1.4.x) or JDK providers (example: Sun JDK 1.3.x to BEA JRockit) than what is shipped with the application server, please visit CERTIFY and check the JDK certification information to ensure Oracle supports this configuration.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.