Help - Search - Members - Calendar
Full Version: Random Shutdown
Linuxhelp > Support > Technical Support
wolfsta
Hey all

Was just at work happily browsing the net and then nothing.

My linux gateway shutdown i found out after pinging from every office i went to check and it was off... no one turned it off or anything..

I checked the log after i turned it back on and i think this is the point where it turned off..

Jun 11 11:51:04 red1 apmd[2257]: System Suspend

am i right? and wat is it?

also i want to move all my dhcp related loggin out of messages can goto /dev/null or into a separate log i dont need it but how do i do it?

Cheers smile.gif
dlab
I think the autosuspend is controlled by your BIOS, and you'd have to disable it there. Apmd just reports on this info and it can execute a command when something happens.
hughesjr
Yes, the computer was set in the BIOS to allow suspending ... and your linux understood the APM setup, so it suspended. You can turn off suspend mode in the BIOS ... and / or you can tell the Linux Kernel not to use APM. On a server, you should probably do both...

You can tell the computer not to suspend by passing apm=off in on the kernel line. You didn't say what distro you are using ... but if it uses grub as the bootloader, put this at the end of the kernel line:

apm=off

in the file /boot/grub/grub.conf
...........
If you use LILO as your bootloader open the file /etc/lilo.conf, and find the section you boot from, then add:
apm=off

inside the :

append = " "

line of that section. Save lilo.conf, then run the command:

lilo
....................
Everything needs to be done as root
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.