Help - Search - Members - Calendar
Full Version: Need Help About Lilo
Linuxhelp > Support > Technical Support
tomamodi
dear experts need help
recently i make ghost copy of my hdd before severel times go through this prosegure never have problem ghost copy will run
this time i copy a hdd (normally system linx) but itwill not boot
mounted on other runnining redhat 9 i check all files are ok even there is lilo.conf
but didnt boot
so i try to /sbin/lilo i lost my red hat boot ! and on boot it give "00000000000" full of screen
how could i repair this unbootable hdd by mounting and repairing
please becarefull you are dealing with newbee give litle more explanation about commands i dint want to reinstall my redhat again
thanks
in short how to repair boot lilo by mounting unbootable harddisk in other running system
thanks again
chrisw
bumping this to the top of tech support after being moved
tomamodi
sorry for posting on rong place
thanks
i hope i get the answer
how to install lilo by mounting the target hdd in working pc with red hat 9
tomamodi
please friends i need urgent help
thanks
Jim
Ok, it sounds to me like the problem isn't on hdb, but hda. Do you ever get to lilo? or when you boot do you just get 000000s on the screen?

If you aren't even getting to lilo, you need to re-install your bootloader.

I believe RedHat has an option to do this from thier rescue tools.

Put your first install disk in and boot. At the prompt, type in Rescue. From there I can't hold your hand because I am not familiar with RedHat enough. But their should be an option to "Restore Bootloader" or something to those effects.

Reinstall your bootloader and you should be set to go.

If you can't find it comeback and I will figuer it out for you. Sorry it took us so long to get to your post.
tomamodi
already i try with cd it say kernel panic didnt have boot disk for this perticular system linux 2.2.19
this is hda but now it is mounted to other running linux system so it is hdc
#linux 2.2.19 unableboot
#how could i trnsfer the system to this
Disk /dev/hdc: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdc1 * 1 25 200781 83 Linux
/dev/hdc2 26 4865 38877300 f Win95 Ext'd (LBA)
/dev/hdc5 26 4849 38748748+ 83 Linux
/dev/hdc6 4850 4865 128488+ 82 Linux swap

i copy this hard disk with norton ghost 2003 before ten copies work good now i think the counts for copy is only ten it write the orignal and now it copy hole disk but unbootable so one must install boot mbr this is lilo
lilo.conf is here
restrected
password=xxxxx
boot=/dev/hda
timeout=50
default=cache
vga = 265
read-only
map=/boot/map
install=/boot/boot.b
image = /lib/modules/2.2.19/vmlinuz
label = cache
root = /dev/hda1
image = /lib/modules/2.0.38/vmlinuz
label = 38
root = /dev/hda1
if chroot this hdc then give
mount /dev/hdc1 /sbin/lilo or lilo -v -v
it change my running grub not the hdc mounted
by rescue way it say
bash: permision denied
dlab
Could you give out some more info on the "000000000000000"? If it is in lilo, then you would see something like "L 00 00 00 00 00 00" or "L? 40 40 40 40 40", etc. Is there a L or something similar appended to the error code at boot?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.