Help - Search - Members - Calendar
Full Version: Xfree86 Help
Linuxhelp > Support > Technical Support

I have a problem running XFree86. I've tried a couple of ways, but none works.

I read this from a Dummy's book but it's for version The one that I have is version 4.3.0. So I don't know whether the instructions apply or not. Anyway, I can't find this command in my system. I can find xf86config though. After some browsing through several sites, I conclude this command is now obsolete. Am I right?

I've tried this method and run startx after configuration. Can't work. The error says this:
Fatal server error:
no screens found
XIO: fatal IO error 104 (connection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining.

Then I tried XFree86 -configure to create the configuration file. After which, it tells me to run XFree86 -xf86config /root/ to see if the configuration is correct. I did as instructed and the screen changes to a blue bar at the top and there was a message saying (something to this effect) 2MB of memory for display. Then it stops there. It then blinks every few seconds. It doesn't seem to react to my input.

I then copied /root/ to /etc/X11/XF86Config. Then I tried XFree86. Gave me the same "no screens found" error.

I'm using Slackware Linux 9.1. My graphics card is S3 Trio32/64. Monitor is Philips 104S. (Ya, I know, all old stuff, but I figured I could put it to better use than leaving it around collecting dust =)

Can anyone help this newbie? blink.gif
What kind of video card are you using? Lots of times linux doesn't include tons of drivers to keep the system from becoming bloated. Instead, you have to go an install the modules for your video card. Write back and tell us what kind of video card you are using and we will tell you where you can get the stuff to install the drivers.

I think you might have a serious hardware problem :

check this link

and this

your card is not supported since 4.1.0 , and Slacware 9.1 comes with 4.3.0,

you should buy a used (or new) GeForce4MX440 or something like that.

Robert B
Hi guys,

Thanks for the replies smile.gif

As stated, my video card is S3 Trio32/64.

I have another Voodoo card lying around (gotta go home and check which series it is). I've checked the status on the Web site (, but it says there is a need for a 'glide' library which is not included in Slackware. Is there any way I can get this installed?
I am looking all over the web for the glide library and I can't seem to find it. The web sight that every one seems to be linking to ( isn't up. Sorry, maybe someone else knows where you can get it, or has it and might be willing to send it to you.

You can try the vodoo card, but I think you might have the same problem since I got the impression that you need the library for the vodoo cards to, but I did find more on the vodoo card.

Google is a great resourse, you can usually type in the piece of hardware and the word linux and find other sources and how to guides from others who have gone before you. If you want the try the vodoo card let us know how it goes and bring back any questions you might have.
Thanks for the help! Will try it and see how it goes.
Hi, just wanna say I managed to get my XFree working. Definitely the video card problem. Didn't use a Voodoo though. Managed to get my hands on a S3 ViRGE. Runs well. Thanks! cool.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.