Help - Search - Members - Calendar
Full Version: Sendmail Not Accepting Connections
Linuxhelp > Support > Technical Support
CNBarnes
Ok, I feel like a dork. I know this has got to be a really easy issue,
but I sure can't seem to find it.

New install of Fedora core 1. yum updated all the packages (incl.
sendmail).

modified sendmail.mc and changed
DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl
to
dnl # DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl

did the make -C /etc/mail

can issue "telnet localhost 25" and get a response as one would expect.
However, nothing is coming in. Telnet to the host from elsewhere (even different computer using same switch - not a firewall issue) using port 25 goes unanswered.
nmap localhost shows "25/tcp open smtp"

http and ssh to the machine are working fine


What am I missing?
hughesjr
what does:

netstat -an | grep 25 | grep LISTEN | grep tcp

Mine says:

tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN
hughesjr
I think the command you want to use to update sendmail.cf is this (from within the /etc/mail directory):

m4 sendmail.mc > sendmail.cf

In order to do that, you will need the following packages installed:

sendmail
sendmail-cf
m4
CNBarnes
that netstat command on my box shows the same result.
I issued the m4 command as shown, restarted sendmail, but still nothing.

Anything else I can try?
Robert83
Hi,

your /etc/hosts file should looks something like this

127.0.0.1 localhost.localdomain localhost
xxx.xxx.xxx.xxx bt.xxxxxxx.co.yu


Sincerely
Robert B
CNBarnes
It (/etc/hosts) does. I also have /etc/host.allow with
sendmail: ALL

Someone suggested doing a tcpdump while trying to telnet to the box on port 25. Here is the output of that:

[root@cornerstone etc]# tcpdump host cornerstone and titan
tcpdump: listening on eth0
11:29:50.870754 titan.42321 > cornerstone.smtp: S 886781666:886781666(0) win 5840 <mss 1460,sackOK,timestamp 41904123 0,nop,wscale 0> (DF) [tos 0x10]
11:29:50.870856 arp who-has titan. tell cornerstone
11:29:50.870984 arp reply titan. is-at 0:7:e9:d:5f:66
11:29:50.870999 cornerstone.tamu.edu > titan: icmp: host cornerstone unreachable - admin prohibited [tos 0xd0]
CNBarnes
Ok, I just found my own answer. The file I needed to modify was /etc/sysconfig/iptables. I had to add the smtp, imap, & pop ports to those that are open.

As soon as I did that, everything worked.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.