Help - Search - Members - Calendar
Full Version: Help I Am A Moron!
Linuxhelp > Support > Technical Support
TomKat
~_~ Well I just installed Slackware Linux both cd of Version 9.1, But when I boot up it does the whole thing where it loads and the penguin watches, then it pops up with a log in that says "darkstar" I put root there then the password I selected during the Setup....
I get a dos like thingy, how do I get the graphical interface to load, auto like Kinoppix?
Adios TomKat
hughesjr
after you log in, type the command:

startx
Jim
if you want it to boot graphically by default you need to edit your /etc/inittab file. You will have to change the line
id:3:initdefault:
to
id:5:initdefault:

If your GUI doesn't start when you type startx that means your graphics card isn't configuered, Knoppix has a lot of the video drivers built in but alot of the standard distros don't so that you only end up with the one you need instead of one you need and twenty you don't.

If its still not working tell us a little about your system but most importatnly what video card you have and we will point you in the right direction.
Corey
omg, this gives me flashbacks of my first ever attempt at linux.

The good ole Slackware 3.5.

"I'm at a black screen, i just logged in as root, where is everything? Where's my programs??? What is this "fortune" game?"

hehe
Jim
Way to date yourself Duende
Termina
You must be pretty old... wink.gif

*basks in the glory, wonder and splendor of youth*

Ho ho!
hughesjr
Corey is a young pup biggrin.gif
dlab
Here is what I did in Slackware 9.1:

Log in as root.

try out some desktop managers like 'gdm' or 'kdm'.
( I prefer gdm because of it ease of use, and it looks nice )

to get back to a terminal, press CTRL+ALT+F1 through CTRL+ALT+F6
to get back to the GUI, press CTRL+ALT+F7
to exit out of GDM (so you can try another desktop manager) type 'gdm-stop' in the shell
to exit out of KDM (so you can try another desktop manager) type 'killall kdm' in the shell

Now that you have found your favorite desktop manager, you can add it to autostart:

At the shell (bash is default under slackware) type:
pico -w /etc/rc.d/rc.local

at the end of the file, add

echo "Loading GUI..."
then gdm, kdm, or whatever you wish to use as your desktop manager.

press CTRL+O then RETURN to save the file in PICO and then press CTRL+X to exit

You should have created a user for youself as logging in as root in a GUI is unsafe.

to add a user type 'adduser' in the shell (adduser is a shell script to add users easier and should be installed with slackware)

log in as that user with the desktop manager and set up your preferences

Also, if your shell says darkstar, then you havent set your hostname yet, to do this, log in as root, and type:

echo 'Your_Hostname.Your_Domain.Your_TLD' > /etc/HOSTNAME

(ex. echo 'abyss.pvboredom.net' > /etc/HOSTNAME)


and then reboot with the command 'reboot'
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.