Help - Search - Members - Calendar
Full Version: Fglrx Help
Linuxhelp > Support > Technical Support
wookmaster
I installed Mandrake 10 a few days ago. It seemed to detect my video card fine it said it was using [Radeon(fglrx)] so I thought great really having luck with this distro. So I download and install the ut 2004 demo to see how it works. I get the splash screen and bam it would just shut down.

Heres the error I would get in the log

CODE
ScriptLog: New Player Player id=32af618f3ba1ef8264f8deefed08553c
Log: Enter SetRes: 800x600 Fullscreen 1
Log: OpenGL
Critical: Couldn't set video mode: Couldn't find matching GLX visual

Exit: Executing UObject::StaticShutdownAfterError
Exit: Executing USDLClient::ShutdownAfterError
Log: Waiting for file streaming thread to finish...


So I decided to try tux racer...ran slow as all hell mouse would barely move.

I decided to try downloading ATI's driver from the website. I download them and try to install. I get this error

CODE
*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Error: no kernel module build environment - please consult readme.


so they have a help file on their site directly related to this error Here

I installed the kernel source, ran the commands they wanted. Reinstalled the driver everything says it works. But when I run fglrxinfo it tells me it's using the mesa driver. I cant get it to use the ATI driver. I tried everything 3 times over with no luck.


If anyone could help me with this I would greatly appreciate. Games are the only reason windows is still a partition on my drive.
wookmaster
also this is what fglrxinfo looks like

CODE
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4



does the extension message mean anything? Thanks
simonau
Try this site it helped for me.
http://rage3d.com/board/forumdisplay.php?forumid=61
Robert83
Hi,

have a look at /etc/X11/FX86Config-4 (or XF86Config)

and make sure that there is a

# === ATI device section ===

Identifier "ATI Graphich Adapter"
Driver "fglrx"

Sincerely
Robert B
wookmaster
I got it workin but UT 2004 runs pretty choppy compared to Windows, wish drivers would work better for this card. Tux racer runs smooth tho smile.gif
hughesjr
You might try 16 instead of 24 bit color .... my frames up by 3x if I do!
wookmaster
It wont let me change it for some reason, I can change the resolution but when I choose the colors it stays at 24bpp nothing else shows up
hughesjr
What I failed to mention was that this is on my NVIDIA card. I'm not sure if you can do it on a RADEON card.

Robert83 would know the answer.
wookmaster
man this thing kicks in windows but it might be worth it to pop in my old GeForce 2 MX 64 meg for some games under linux smile.gif
hughesjr
Mandrake 10 is kind of wierd about drivers...

you might be able to edit your /etc/X11/XF86Config-4 file directly ... (back it up first).

look for a section that looks similar to this:

CODE
Section "Screen"
       Identifier "Screen0"
       Device     "Videocard0"
       Monitor    "Monitor0"
       DefaultDepth     24
       SubSection "Display"
               Depth     24
               Modes    "1024x768" "800x600" "640x480"
       EndSubSection
       SubSection "Display"
               Depth     16
               Modes    "1024x768" "800x600" "640x480"
       EndSubSection
EndSection


If there is no Depth 16 SubSection "Display"
CODE
       SubSection "Display"
               Depth     16
               Modes    "1024x768" "800x600" "640x480"
       EndSubSection


... just copy the Depth 24 SubSection "Display" and pasted it below the current Depth 24 SubSection "Display" ... but before the EndSection for Section "Screen" .... then just change the DefaultDepth to 16.

Now ... Mandrake 10 is funny ... so after you reboot, edit the file again and make sure the changes took.
wookmaster
says the fglrx driver doesnt support 16 bit and kicks me to the console

sad.gif
hughesjr
Good thing I said to backup the original file laugh.gif

I guess that the speed is what it is at the original setting....
wookmaster
well I dont have a way to play 3d games good yet, but I sure learend ALOT about the console trying to get X to work smile.gif
Hemant
This link is worth reading.If you want to install ATI drivers.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.