Help - Search - Members - Calendar
Full Version: Help Setting Up Postfix
Linuxhelp > Support > Technical Support
Corey
Okay, i followed the guide step-by-step using Whitebox linux for my install.

My network is setup like this:

192.168.0.1 - Linksys router, connected to the internet, port forwarding 110,25,80,443 to 192.168.0.2
192.168.0.2 - Mail server, firewall is open for 110,25,80,443
192.168.0.10-12 - Client computers.

domain: thegoodtimes.ca
mail: mail.thegoodtimes.ca

Okay, so, from my computer (192.168.0.10), i can 'telnet 192.168.0.2 25' no problem, i get the postfix screen. Same with 110. When i ssh to a friends computer out on the internet, and try to telnet back to my mail server at port 25, it times out. When i try for port 110, it connects fine. I've double-checked my port-forwarding, and it is set up correctly.

So, i'm thinking it's something in the postfix configuration file, something with these lines:

QUOTE
# RECEIVING MAIL
inet_interfaces = $myhostname
proxy_interfaces =


Any ideas if this is even the problem?
Robert83
Hi,

all my smtp port problems were related to

/etc/hosts file

127.0.0.1 localhost.localdomain localhost (? or something like this, doing this from winXP)
192.168.10.2 mail.test.local
217.xxx.xxx.xxx mail.test.local ( if you have a public , I think you should enter the mail.test.local here to... or even try removing your private ip adress , and add the hostname only to the public)


Sincerely
Robert B
Corey
THe problem with that is that I don't have a static IP to put there, I have a dynamic ip. I'm using hugh's script to update my domain names via zoneedit.com.
hughesjr
What does netstat -an | grep LISTEN | grep 25 say?

.... you might try:

inet_interfaces = all
hughesjr
Also ... try this:

proxy_interfaces = mail.whatever.com

(substitute the name you have assigned to your mail domain in the MX record at zoneedit.com) (for me, mail.hughesjr.com)
Corey
As it turns out, me and Joey (well, mostly Joey) determined that my port 25 was being blocked by my ISP, after some searching, Joey came accross some proof on dslreports about it. They have blocked incoming and outgoing requests off that port. i will try and contact them about allowed outgoing port 25 traffic which would help a bunch.
hughesjr
on the outgoing, you might just be able to send via their mail server (here is an example, you want to make your ISP the relayhost, not just a transport ... and you may (or may not) have to use SMTP AUTH outgoing) ... it won't help the incoming though. If they don't allow incoming, you won't be able to recieve mail into the server directly.

But, with zone edit, you can do mail forwarding ... so that all mail at that domain.com gets forwarded to your current ISP mail box....

So if you can orute the outgoing mail through the ISPs mail server (they usually allow that ... for sure if they allow SMTP AUTH ... and you can get the mail back via your normal account you should be good.
hughesjr
and if robert hurries up and figures out the fetchmail smile.gif , you can suck it down from your ISP onto the server!
Corey
Well, i got the mail problem pretty much figured out thanks to hughsjr and Joey.

First off, to back track. my ISP blocks incoming and outgoing port 25 *unless* it's using their smtp servers. As well, their smtp servers does not require authentication, as long as your on their domain (which I am). So, I can now send mail fine using their servers as a smart host.

Now, with receiving mail, I am currently signed up (thanks to joey) with mxlogic that filters my mail from spam and viri and then forwards them along to a mail server. Luckily, they have the option of me being able to choose what port to send mail on, so i set it up to send it to me on port 26, then configured my router to receive on port 26 and forward internelly to my mail server on port 25.

I'll do more testing today, but i think it's working well.
hughesjr
that'll teach those silly ISPs ... we can get around their futile attempts to stop us from doing what we want!
Corey
...because we're 31337 4ack3r5
Termina
*uncaps his modem, and posts warez on newsgroups because breaking an ISPs rules can only be a good thing*

wink.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.