Help - Search - Members - Calendar
Full Version: X Problem With New Shrike Install
Linuxhelp > Support > Technical Support
wjt
This is new for me, so any advice would be greatly apprciated... I have looked in documentation and around-and-about,... no luck yet...but I'm continuing to peruse.

With a new RH 9 (Shrike) install X won't configure and reports ramdac read failure and no video card. However, if the install is started with "linux skipddc", X does configure during the installation program phase. But, when it boots afterward to the installed system, same problem... ramdac read failure.

This happens on two different pentium platforms (100 and 166 mhz), both 128 MB, and multiple video card attempts, including legacy Western Digital EISA, PCI Mach64 and PCI Diamond Stealth64. All work flawlessly under windoze.

Is there a configuration file I can modify to force the effect of "skipddc"?

Also, this seems fairly strange to me. Can someone help me understand how these fairly common video cards would be having difficulty with this very mature OS distribution?

Thanks in advance for any comments and assistance. This old hack need all he can get!

Joe
Hemant
The one solution could be...edit file...
/boot/grub/menu.lst and add the linux skipddc
Hemant
skipddc is used to skip the automatic detection of video card.So once you have skipped that ( i don't think that was a great idea,rather you should have proceeded to install in text mode).

How did the whole install go?? was it in X-mode??( i don't think so..) or in text mode. How did you configure X??

Well one thing at a time..Though Linux is pretty much mature now..But there are few nasty hardware problems ( Mostly because of stubborn hardware manufacture who don't want to reveal their architecture).

First of all we have to understand what is Ramdac?? Well this is a chip..which converts the digital information of video Ram to analog before sending it to the monitor..( coz monitors can handle analog signals only)..Now Ramdac failure can occur in two cases:-
1.Your Ramdac chip is really corrupt( well it is really possible!!!)
2.The second problem could be..becuase of incorrect video card detected by the OS..So all the wrong signals!!!

Second case suits your problem...If after putting linux skipddc at the boot prompt(during installation) if the installation went quite normally in X-mode ( did it?? ) then your problem is half solved!!!

But if after putting linux skipddc at the boot prompt..installation proceeded in text mode..Then..i think you have will have to disable few devices for the time being from BIOS..Apart from Video-card,Sound card..what other devices you have on your mother board???for example...Ethernet card,Scsi devices..

Now what you do is..disable these devices( the extra ones) for the time being from BIOS and proceed to install Linux.After installtion...just enable then and Kudzu will automatically detect them!!!
Hemant
As..for your question where should i put skipddc line...It has to be on kernel line
wjt
Yes, "linux skipddc" did allow the install in X. I find this problem strange because it occurs with different video cards that are common, well featured and otherwise seem to work, and on different pentium platforms. Maybe it's the rainy weather we are having... wink.gif

Anyway, then, I placed "skipddc" at the end of the kernel command without success... I used this syntax:

kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ skipddc

I thougt it useful to follow the advice given to another user to collect the output from "startx" using the form "startx > startx.output" but this is giving me difficulty.

Other commands such as "dir > stuff.out" do redirect the output to the file. startx does not. It still comes to the screen, and the file startx.output is present in the directory but is null.

startx refers to the file /var/log/XFree86.0.log but it is quite lenghty, and I wonder if it is useful to post it here.
wjt
Okay, I feel stupid, but here is some more information...

Because all these symptoms seemed so goofey, I decided to repeat the install just to reproduce the results, and discovered better information. I had tried different things, and falsely recalled what made X run. ...sorry...

It wasn't "linux skipdcc" that allowed the installation to run with X active. It was "linux noprobe" that did this.

Using "linux noprobe" the installation always runs with X in graphics mode.

Extrapolating the previous advice I changed the command line in menu.lst from "skipddc" to use the "noprobe" option (assuming this makes sense). This changed the menu.lst command line to:

kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ noprobe

But, no joy. The system still boots claiming there is no recognizable video.

To review the configuration... (RH Shrike release)

The video cards include Western Digital Paradise PVGA1A, Diamond Stealth 64, and ATI Mach64. I may be incorrect, but I believe these are very common and capable video cards. I have also tried this on two different motherboards, one a Pentium 100, and the other a Pentium 166 MHz.

Any idea what I'm missing here? Thanks for any thoughtful suggestions!

Joe
Hemant
QUOTE
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ noprobe


Actually it is quite stupid to put noprobe on the kernel line..coz noprobe is used during installtion do disable hardware(most of the) detection..But of course you'll want your hardware to be recognised..while normal booting!!!!

Now did you configure X properly ??? What if you don't enter linux noprobe during installtion???

I think as noprobe disables detection of most of the hardware and you have to configure everything manually....So somewhere X-configuration gone up the spout!!!!!
wjt
Okay, point taken...

Interestingly enough, the installation did proceed with X active using linux noprobe, but when booted normally using noprobe on the kernel line, X does not start. But, all hardware was detected though, so I wonder about the effect of noprobe on the kernel line.

So, it seems I need to manually configure the video. I remain very puzzled why these cards are not recognized, but that seems to be the case. Perhaps I can find another common card and try it. I will also look for a list of supported video card types and this may save me some time.

Thank you for your assistance!
Hemant
One more question...
Do you have any other device apart from sound card,video card
on your motherboard??
Like..ethernet card,scsi devices
hughesjr
as part of the install, did it ask you to pick your X configuration?

do you have a file named:

/etc/X11/XF86Config

if so, try editing that file and look for a section for your video card ... mine looks like this on one of my servers:

CODE
Section "Device"
       Identifier  "Videocard0"
       Driver      "ati"
       VendorName  "Videocard vendor"
       BoardName   "ATI Mach64"
EndSection


Change the Driver line to:

Driver "vesa"

and see what happens...
wjt
BINGO!

Many thanks!

"vesa" did the trick... At least X started, and now I can see how everything else is working...

As for other devices on the motherboard... there is an integrated sound chipset and IDE controller. That is all. Other than the PCI ATI Mach64 video card, I have installed a PCI 3Com Ethernet card, and it seems to initialize and fetch an IP address from my router without any difficulty.

Please accept my thanks all around for your continued support through this puzzling problem!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.